How to set default search window "Open in Find Window"

Hello, how can I set the default so when I do a "find" it shows in the Find Window at the bottom, not in that popup?

Thanks

14 comments

No no no no no no, I hate this preview window.  I don't want the preview window, I literally always want the find window.  This has messed with my workflow for months.  How do I get the preview window to go away and die forever?

15

Ermahgerd after digging through Andriy's link I eventually found this:

 

Help > Edit Custom Properties

Create the file if it doesn't exist, then add this line:

ide.find.as.popup=false

Solves all your problems, baby.

12

very very happy to see this thread - this window has been one of my two biggest intellij pain points - and now that it's gone with a simple "registry" change, my life is much better.   Thank you!!

1

Hi there,

It's only a preview -- it was like that even before .. but it was shown in separate tab so you may simply not seen it.

Right now -- after you have typed your search query -- just press Ctrl+Enter or click that button on the bottom right -- it will open search results in dedicated tool window just as before.

0

Thank you Ian Cervantez - did the trick!

0

Remember to restart your IDE..

0

I'm a bit late, but thanks Ian Cervantez :)

0

Ian Cervantez, you are my hero! That stupid preview window was making me insane. Thank you!!

0

Any chance to make this a real option?

It feels like being hidden away means that it might be removed at some point and the popup search is a very poor substitute

0

Please check this comment for a workaround: https://youtrack.jetbrains.com/issue/IDEA-169996#focus=streamItem-27-2520331.0-0
We don't plan to change the default behavior.

0

Please sign in to leave a comment.