Format Space within braces for ES6 import/export

I haven't been able to figure out how to set format to add or retain the spaces within braces for TypeScript / ES6 import/export. 

So I want

```
import { Component, EventEmitter, OnInit, Output, Input } from '@angular/core’;
```
 
Instead of 
 
```
import {Component, EventEmitter, OnInit, Output, Input} from '@angular/core';
```
8 comments

please try enabling Preferences | Editor | Code Style | TypeScript, Spaces / Within / ES6 import/export braces - does it help?

18

That was it - thanks (I totally didn't see that option before.) 

0

Upvoted. This helped me greatly.

Never thought Typescript will be a separate option in the list of Code Options.

0

Is this option also available for Resharper?

0

Unfortunately, at this moment there is no such option in Resharper.

Please vote for this feature https://youtrack.jetbrains.com/issue/RSRP-465954 to increase its priority and to be notified about updates.

0

Thanks @Elena, your solution fixed my problem! My imports are now spacing correctly.

0

Please sign in to leave a comment.