Problems with setuping Remote PHP Interpreter via SSH from virtual windows to windows

I'm trying to setup PHP remote interpreter.

I have a host with PHPstorm on Windows 10.

I have a virtual machine on Windows Server 2016 with PHP 5.3 on it.

I have woorking SSH between them. I go to Settings -> Langs -> PHP -> CLI Interpreters. Then I need to choose PHP executable. SSH works normally, I currectly can find the forder with PHP on remote machine. But after that, first time phpstrom said there is no this place on remote server (wat oO?), now it says "Can not update phpinfo: Failed to parse validation script output".

What should I do?

Thanks.

13 comments

Hello,

It looks like we do not support the remote Windows interpreter via SSH.

It would be great if you could submit the feature request to our tracking system here: <http://youtrack.jetbrains.com/issues/WI#newissue=yes>.
You will be able to receive the answer directly from our developers while other users will be able to write their opinion of your proposal.

0

Oh,,,
May be I can use something instead?

Are there any ways to use virtual windows server with PHPstorm?

0

Not really, only running PhpStorm there, in the VM.

0

The same thing happens to me running PhpStorm 2017.1 on Linux Mint 17.1, and trying to set a remote interpreter located on a Vagrant virtual machine (Laravel Homestead, to be precise). If I set the interpreter to '/usr/bin/php' it's detected but if I set it to /usr/sbin/php-fpm7.1, which is the one want to use, it isn't deteced.

Vagrant option:

SSH option:

0

Hello Michał,

What PhpStorm version do you use?

0

2017.1, as mentioned in the beginning of my post :)

0

Please set php-fpm7.1 as an interpreter via a Vagrant configuration, click refresh and then collect and upload the IDE log somewhere.
I expect the error to be explaned in the log.

0

Thank you for your swift answers. You will find the log file here: http://wklej.org/id/3216824/

0

php-fpm7.1 isn't accepting -dxdebug.remote_enable=0 parameter for some reason.

Could you please try to ssh into that vagrant box and check if it accepts xdebug parameter correctly? This would looks like: 

/usr/sbin/php-fpm7.1 -dxdebug.remote_enable=0 /some/php/file.php
0

I'm afraid php-fpm (7.1 in this case) is not designed to be run from a command line. Normally the scripts are forwarded to it through a socket from something like Nginx webserver, therefore I cannot perform the test you have suggested unfortunately. If you have any other idea on how I could debug the situation further, please let me know, I will be happy to assist.

0

>I'm afraid php-fpm (7.1 in this case) is not designed to be run from a command line.

Then ... how do you plan to use it as PHP Interpreter in PhpStorm (which will use it in CLI mode)?..

Maybe you simply do not need it at all (e.g. you are creating it just because you can)? For web debug (via browser) you do not need any PHP Interpreter.

0

No, I'm going to do PHP debugging, I'm pretty sure I need it :).

I guess you're right - it seems the -fpm version of PHP is unable to work with PhpStorm, though I saw some tutorials saying otherwise, which is why I kept asking.

The reason I would like to use the /usr/sbin/php-fpm7.1 binary instead of /usr/bin/php (which also exists on my server and works with PhpStorm) is because on my virtual machine only the -fpm7.1 version has Xdebug installed. It would be a bit cumbersome for me to install it for the CLI version of php every time I destroy the virtual machine or to find a way to automate it. But it seems I have to.

0

>No, I'm going to do PHP debugging, I'm pretty sure I need it :).

My question here was: do you really need a CLI for debugging?

My point is: if you will be debugging your web pages only .. then you do not really need it (CLI) and you just use your fpm version (as that's what your nginx is using).

But yes -- for debugging cron jobs and scripts in CLI mode you will have to have xdebug in your php that is run in CLI.

0

Please sign in to leave a comment.