DataGrip - Dump Data is disabled


I'm trying to export my query results to CSV or TSV, but I've never been able to use the dump data option, because it is disabled (greyed out).

I've tried registering my license again, and playing around with the data extractor file configurations, but no luck so far.

I might be missing something elemental, any help is appreciated.


No worries, just glad we're seeing the same behavior ... hopefully the developers are pointed in the right direction.


Also having the same problem in 2017.2.1 on Windows with a SQL Server 2014 database.

Closing the connection using the Database window and then re-running the query let me work around it.


Am having the same problem, and none of the above work-arounds have helped. Am executing a select statement only, using a new connection where the full connection parameters have been specified (schema and database), with a new database console. Always the dump options are disabled. Have tried everything, including restarting PyCharm. This is with version 2017.2.


@Emmet Murphy Hi,

A possible fix is available in DataGrip 2017.3 EAP. In your case in PyCharm 2017.3 EAP.

Thank you.


I was able to enable the button "Dump data" by unchecking the "Limit page size to" in file->settings->Tools->Database->Dataviews.



Please sign in to leave a comment.