Smart code completion broken by 2017.1 update?

Answered

The smart code completion for things like method names and property names (in Maven POM files particularly) seems broken after the latest update.   When I try to enter a property name, it seems like after every keystroke IntelliJ goes into some kind of build or recompile, and even if the typeahead dropdown is showing (attachment included) it doesn't work correctly.   If I press "Enter" to accept the typeahead option, Intellij simply ignores the typeahead and inserts an "Enter" into the code.   

Is this a known problem?   Is there a setting I can change to get around this behavior?

2 comments

Pre-select doesn't work automatically depending on the context, use up/down arrows to select or use Ctrl+Space for the explicit completion with automatic pre-selection.

Disable Maven project automatic import. pom.xml files are saved automatically on editing which will trigger reimport on every keypress if autoimport is enabled.

1

Thank you!  Turning off the auto-import improves things immensely.

0

Please sign in to leave a comment.