Module groups Configuration get lost after IntelliJ Restart

Answered

Hi,

wenn i add a new logical Group with "Right Click" --> "Move Module to Group" --> "New Top Level Group" --> "Name:" everything works fine.

But as soon as i close my IntelliJ and reopen it all logical Group configs are lost. How do i get logical Groups to work?

 

The solution for

https://youtrack.jetbrains.com/issue/IDEA-110252

doesnt work.

 

6 comments
Comment actions Permalink

I have the same problem with Gradle-based modules. Every time build.gradle changes the module looses its grouping - so annoying!!!!

https://drive.google.com/file/d/1qGEhNkStCbbyfS7vPE62n9fsTfclN0cC/view?usp=sharing

2
Comment actions Permalink

Thanks, I know these issues - I'm one of the contributors. These issues are open forever and very annoying if you have larger projects with multiple modules.

Your suggested option does not help in mixed environments (Gradle and none Gradle modules). 

1
Comment actions Permalink

If your project is Maven based, this behavior is expected: https://youtrack.jetbrains.com/issue/IDEA-139882.

0
Comment actions Permalink

We dont use Maven at all. Its plain Puppet - Ruby code. I even tryed enabling and disabling the option from the BUG 139882 but nothing happend.

0
Comment actions Permalink

In this case please file a new bug at https://youtrack.jetbrains.com/issues/IDEA and attach the sample project with the steps to reproduce it.

0
Comment actions Permalink

@Mike your issue is Gradle-specific. See https://youtrack.jetbrains.com/issue/IDEA-153496 / https://youtrack.jetbrains.com/issue/IDEA-149753.

Btw you can consider the Preferences | Build, Execution, Deployment | Build Tools | Gradle | Group modules: using qualified names option.

0

Please sign in to leave a comment.