Console toolbar is gone

Answered

I am running the latest pycharm 2017.1.2 version and I noticed that the console tool bar in the debugging mode is gone: https://www.jetbrains.com/help/pycharm/2017.1/debug-tool-window-console.html

I am looking for the "Show Python Prompt' button which allows me to add python commands during debugging mode. This was very useful, did you remove this option ?

 

With kind regards

Eelco van Vliet

 

10 comments
Comment actions Permalink

Hi, Eelco! The button should be there indeed, maybe your debug pane is too small so the button was collapsed inside spoiler? Could you  screenshot the whole pane and attach it here please?

0
Comment actions Permalink

Hi Pavel,

 

I made sure I enlarged the console tool bar. I see now, however, that I am missing the whole second vertical tool bar with the softwrap and trash icons. Please have a look at my screen shot. Perhaps I have accidentally hiden it. Do you have any idea to get the console toolbar back ?

 

Eelco

 

0
Comment actions Permalink

All,

The problem was solved: just delete the .PyCarmCE2017.1 directory and restart pycharm. that brought back my debug toolbar

PyCharm support: thanks for the quick help!

Regards

Eelco

0
Comment actions Permalink

+1

I am also experiencing this problem.  Has the root cause been identified?

0
Comment actions Permalink

I figured out one root cause for this problem.  

I had to uncheck "Emulate terminal in console output" in my active Run/Debug configuration.  (Reference https://www.jetbrains.com/help/pycharm/2017.1/run-debug-configuration-python.html?search=configuration).  While emulating a terminal, the entire secondary console toolbar disappears, including the "Show Python Prompt" button.

3
Comment actions Permalink

I try to add "Emulate terminal in console output" button and the problem not solved yet

 

 

 

0
Comment actions Permalink

Ok, I resolve the problem.

You need to click on this button and you will show the console.

5
Comment actions Permalink

I'd like to point out exactly where this is found in the menu system, since I just spent several hours confused about why I couldn't debug my scripts using the console. From the Run menu, choose Edit configurations > deselect "Emulate terminal in output console" 

This will display the console toolbar (second vertical button bar) allow you to debug with the console.

0
Comment actions Permalink

For everyone coming from an IDEA product that does not have the 'virtual/emulate terminal yadda yadda' option in the run configuration settings (e.g. GoLand):

 

You can find the corresponding setting via the registry (CTRL+SHFT+A, type: registry): run.processes.with.pty

Uncheck the checkbox and execute your run configuration again. Solved it for me in GoLand 2019.2.EAP.

 

Cheers

 

P.S. I filed a bug report, maybe upvote? https://intellij-support.jetbrains.com/hc/en-us/requests/2178944

0
Comment actions Permalink

 if you click here, the console pane will hide to top right corner. then click it your pane will appear.

0

Please sign in to leave a comment.