Any way to force new line parsing on variable inspect?

Can't find any option to split string literals on \n or any other line breaks when debugging and inspecting string variables.

Makes for a rather annoying experience when checking json and similar.

8 comments
Comment actions Permalink

Not sure i follow you... Please see https://youtrack.jetbrains.com/issue/WEB-12359 - is it the issue you are talking about?

0
Comment actions Permalink

Similar, but not exact. I'm talking specifically about using the "inspect" command to inspect a variable when debugging - large new window, but still just one line trailing off.

0
Comment actions Permalink

there is a 'View...' link in the upper right corner that allows viewing the wrapped value

 

BTW, it's also available in watches

1
Comment actions Permalink

It's not the wrapping that's the issue, it's the line breaks not being parsed.

0
Comment actions Permalink

what do you mean by parsing? Displaying `\n` as a line break? All fields in watches/evaluate/etc are single-line

0
Comment actions Permalink

Yes, exactly that. Be it a toggle, a command or apply for only single inspects, but have a way to do it.

0
Comment actions Permalink

there is no such option, please feel free to file a feature request to youtrack

0
Comment actions Permalink

I have just found this issue and see no resolution. Has the feature been added? It's hard to believe those of us debugging JSON or SQL or any other multi-line text formats haven't also asked for this feature but I can't find it.

0

Please sign in to leave a comment.