Disable automatic theme switch

I'm new to this and it might sound silly, I apologize for that, but it's getting me crazy...

The first time I changed editor colors I was offered to switch automatically theme as well and I did that. But now I'd like to disable that and I don't know how to revert that! I uninstalled and removed preferences and all...

How can I do that?


Hi there,

There are 2 separate things that you can change (manually, at any time):

  • GUI Theme -- "Settings/Preferences | Appearance & Behaviour | Appearance"
  • Editor Colors -- "Settings/Preferences | Editor | Colors & Fonts"

Thanks Andriy, but it doesn't help. I did as you advice and if I change theme, it's fine, say the default light... If then I pick a color scheme that's dark, for example Monokai, the theme switches automatically back to dark (dracula). I just don't want it to automatically do that.

There's a way to work around it, and that's setting theme in preferences and switching colors using the switch from the interface (I mean not from the precences pane).. But I would just like to revert this behaviour and/or remove all set preferences. Do you know how to do that?


What OS you are on?


mac OS 10.12.5


There is no GUI setting for that (AFAIK) -- it has to be done by editing the config file directly.


So .. for you it should be ~/Library/Preferences/PhpStorm2017.1/options/options.xml (or just search for "options.xml" file in "~/Library/Preferences/PhpStorm2017.1" folder -- sorry, I'm on Windows and cannot confirm the exact Mac path)

  • Make sure that IDE is closed
  • Open the aforementioned file in any plain text editor
  • Look for <property name="change.laf.on.editor.theme.change" value="true" /> node and delete it
  • Save file and launch IDE.



Since I'm not 100% sure on what you mean by "switch from the interface" ... so I may be repeating what you already know .. but anyway:

Alternatively you may try "View | Quick Switch Scheme..." -- if done through that it may not apply that "automatic" logic (at very least that's how it works for me -- if I change schema via Settings, it will ask (as I have not checked that option); but if I do with Quick Switch -- it will not).


Man you are great! It works like a charm 🎉

Thank you so much!!


I am using IntellijIdea2020 and my L&F automatically changes to dark mode. 

Each time I switch to "Macos Light", it switches back to dark mode the next day.

How can I prevent this happening automatically for IntellijIdea2020? 


@Halil Karakose


Does it happen the same day but just after IDE restart?

It keeps the last used theme here, no issues at all (Windows 10, PhpStorm 2020.1.1). I can choose dark GUI theme and light editor colors .. and it will keep it like that after the restart.


My only guess right now:

1) You may have some issues with IDE saving the config files properly. Check idea.log file (Help | Show Log in XXX) for possible exceptions or other hints.

2) Maybe you have Settings synced with some online storage? There are 2 bundled plugins: "IDE Settings Sync" and "Settings Repository" -- maybe they do not sync it well? Try with those plugins disabled to see how it will behave.


I am trying with "IDE Settings Sync" disabled.


As of now, the problem is not occuring any more. Disabling "IDE Settings Sync" worked. Thanks Andriy Bazanov!


Select Preferences, then Appearance & Behavior, Appearance, and you will see next to the theme, a checkbox labeled "Sync with OS". Uncheck the box to prevent automatic Light/Dark switching.


I have a problem: the Sync with OS button is not shown up.


What OS are you on? This option is not available on Linux


I'm in Linux, but had the option at first start to set it to OS synchrony.


Please sign in to leave a comment.