sbt issue in IntelliJ IDEA 2017.1


I have a problem with IntelliJ IDEA 2017.1 and sbt. Though I don't use any proxy, ctnlm or something like this, I get the following error every time I try to update sbt project or create new one:

Getting org.scala-sbt sbt 0.13.13 ...

:: problems summary ::
            module not found: org.scala-sbt#sbt;0.13.13

    ==== local: tried


      -- artifact org.scala-sbt#sbt;0.13.13!sbt.jar:


    ==== Maven Central: tried

      -- artifact org.scala-sbt#sbt;0.13.13!sbt.jar:

    ==== typesafe-ivy-releases: tried

    ==== sbt-ivy-snapshots: tried


            ::          UNRESOLVED DEPENDENCIES         ::


            :: org.scala-sbt#sbt;0.13.13: not found


    SERVER ERROR: Parent proxy unreacheable url=

    SERVER ERROR: Parent proxy unreacheable url=

    SERVER ERROR: Parent proxy unreacheable url=

    SERVER ERROR: Parent proxy unreacheable url=

unresolved dependency: org.scala-sbt#sbt;0.13.13: not found
Error during sbt execution: Error retrieving required libraries
(see C:\Users\user-name\.sbt\boot\update.log for complete log)
Error: Could not retrieve sbt 0.13.13

Process finished with exit code 1

I search possible causes and solutions on Google, Stack Overflow and here, but I didn't find anythign that helped. I'd be grateful fro Your help.

Comment actions Permalink

Hi, can you please check the following:

  • Are you using the option "use sbt shell for builds and imports" in your project?
  • Do you have a proxy configured in your IDEA settings? (Appearance & Behavior / System Settings / HTTP Proxy)
  • Does resolving the files work when you use sbt from the command line?
Comment actions Permalink

Ad.1 - No, I don't.

Ad.2 - No, I don't.

Ad.3 - What I attached is the result from IntelliJ SBT Shell. I don't use separate sbt, so I can't verify that. I deleted .sbt and .ivy directories while I tried to fix this issue, so all that happens when I start that shell is downloading new sbt files. Which fails all the time.

Comment actions Permalink

Thanks for checking.

This does look more like an issue with sbt or your system's configuration than with IDEA. To confirm,

  • can you please try installing sbt standalone ( and see if it fails to download as well.
  • or just try opening this file from your browser:

Also, when you start the built-in shell, what is the complete first line? It should look a bit like "/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java -Xmx768M -Didea.runid=c411d7f1-75fe-41cd-9033-4c000a277eee -jar "/Users/jast/Library/Application Support/IntelliJIdea2017.2/Scala/launcher/sbt-launch.jar" idea-shell"

Comment actions Permalink

I suppose it was something with system configuration and/or some really low-level IDEA configuration. I installed standalone sbt and it didn't change anything - the error was the same. I also could download ivy.xml file from the browser. Ans the first line looked like Yours.

However, in my last attempt I installed Community Edition version and it worked there. Suprisingly, it also stared working in my Ultimate version. I really don't know what was wrong, but I'm glad it is operable again. 

Thanks a lot for Your help. :)


Please sign in to leave a comment.