Unable to access git repo: SSL certificate problem: self signed certificate

I am running an ordoid server with installed Gogs (which is alternative to gitlab) because gitlab does not run well on that arm architecture.

Gogs is accessible via apache which has correctly configured SSL support,

I am using a self signed certificate!

So when i try to access a repo on the address https://git.domain.com/user/repo.git i get the erro above.

I did a search at the communiti but with no luck.

So any suggestions are welcomed.

Comment actions Permalink

Did you try to access this resource via Web browser - does it work?

Do you have this certificate listed in File | Settings | Tools | Server Certificates afterwards? You can try to check "accept non-trusted certificates automatically" there.

Comment actions Permalink

Yes, it's accessible through web browser. i save the certificate and insert it into the project.

Also checked the second solution but still no luck

Comment actions Permalink

UPDATE: Since this migt be a cery private case in the mean time i did sign up for a SSL certificate from Let's Encrypt (that's not an ad!!). The config went well and now everything is running just fine.

So my suggestion is get a SSL certificate - from where i got it it's free. The only drawback is that you have to renew it every 90 days :)

Comment actions Permalink

me to. i got same problem. it works with different tools, but not with phpstorm. Thank you for your solution idea, but it really can not be (long-term)

Comment actions Permalink

Was able to access the resource via the web-browser on Windows.

The following steps solved it for me:
1. Go to: File -> Settings -> Advanced Settings
2. Check  the "Use Windows Certificate Store" option


Please sign in to leave a comment.