Build process stuck

Answered

Hi, I can't build any project when I try to run the main class.

Build process just keeps loading forever without showing any error.

Here are some pictures http://imgur.com/a/onHRw 

I run the community version x64 bit 2017.1.3 (build IC-171.4424.56).

Java x64 bit (sdk) 1.8.0_131.

 

I tried compiling and running a simple hello world project in cmd and works fine, also I tested on others IDEs and they work too.

I don't know if this is saying anything but java.exe in task manager remains at 77mb constantly while build process keeps loading. If I force end process on java.exe from task manager, the console pops up in intellij (check the link for pictures).

How can I fix it? Thanks.

3 comments
Comment actions Permalink

Try getting the thread dumps from the JPS (build) process to see where it's stuck: https://intellij-support.jetbrains.com/hc/articles/206544899.

File an issue at https://youtrack.jetbrains.com/issues/IDEA with the thread dumps and the logs attached (https://intellij-support.jetbrains.com/hc/articles/207241085).

See if disabling the antivirus/firewall helps.

0
Comment actions Permalink

antivirus/firewall are turned off, also tried installed/uninstalled intellij/java/sdk several times + dl an older version of sdk and still didn't work.

I will post the issue with the logs in the link you specified @Serge

Thanks

0
Comment actions Permalink

Please see if the issue is still actual in the current IDE version: https://www.jetbrains.com/idea/download/index.html .

0

Please sign in to leave a comment.