auto-collapse imports STOP

Is it possible to tell ws to NOT collapse the imports at the top of the a ts when I open the page?  

5 comments
Comment actions Permalink

You can disable imports folding in File | Settings | Editor | General | Code Folding. But note that code folding options only work on initial file loading, folding state of opened file is saved and restored in file reopening

11
Comment actions Permalink

I'm not seeing "General" in my settings. I'm using:

IntelliJ IDEA 2017.2.5
Build #IU-172.4343.14, built on September 25, 2017
You have a perpetual fallback license for this version
Subscription is active until August 27, 2018
JRE: 1.8.0_152-release-915-b12 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.6

0
Comment actions Permalink

You have opened File | Default settings; please open Idea | Preferences instead

1
Comment actions Permalink

Elena's path is incorrect now (at least on MacOS), it should be:

Idea | Preferences | Editor | General | Code Folding

2
Comment actions Permalink

Path is correct; File | Settings is a path on Windows/Linux, on mac it's <IDE> | Preferences. See https://www.jetbrains.com/help/webstorm/2019.2/configuring-project-and-ide-settings.html#access-project-settings

0

Please sign in to leave a comment.