Issues with offline inspection

I've been trying to set up inspections to run from a command line. I am working in Window 10 and a Ubuntu 16.04 virtual machine out of the same project dir. I'm not sure if that has screwed something up, but I'm having issues both running things and viewing results.

When I run Code->inspect I get many errors. When I run the command line inspection from windows I get:

"""

Opening project... done.

Initializing project... Loaded profile 'Default' from file 'C:\path\to\my\file\Default.xml'

done.

Inspecting with profile 'Default'

Scanning scope...

Processing project usages in [prj] - ...\my\file.py

Analyzing console in [prj] - ...\my\file.py

Done.

"

I then have 2 files. SpellCheckingInspection.xml which contains typo info and .descriptions.xml which contains inspection results.

However, when I load it into pycharm with Code->View offline Inspection Results only the spelling checks come up. 4/5 of the checks say "Type: In word 'foo' No longer valid"and points to the wrong line

When I run in my virtual machine I get similar to the above output, but there is no output for processing the code. The output has 'PyMissingOrEmpytyDocStringInspection.xml' (9 lines long). When I try to view these errors in pycharm I the only error is that the __init__.py file doesn't have a docstring.. (has #!/usr/bin/env python in it...)

Below is an example of how I'm kicking off the script in my Ubuntu virtual machine. The windows command is done in the same way.

 /path/to/pycharm/pycharm-community-2017.1.3/bin/inspect.sh /path/to/prj/ /path/to/profile/Default.xml /path/to/output/ -v2 -d /path/to/sub/dir/

I've not seen anyone complaining about this so it seems like user error, but I'm not sure what is going wrong.

Please sign in to leave a comment.