TSLint not showing errors (but Typescript ones do)

I have an Angular project which was previously working fine, but now the TSLint errors do not show in PHPStorm.

 

Running tslint <file> in the commandline gives proper output, and Typescript errors (and other PHPStorm inspector errors) do show up fine. The TSLint config in the project settings seems to be okay, and picks up my node and tslint binaries. I also checked the inspector settings and TSLint errors are set to 'error' still.

 

How do I get the errors back?

9 comments
Comment actions Permalink

Do you have TSLint inspection (Inspections | TypeScript | TSLint) enabled?

Please provide a screenshot of Settings | Languages & Frameworks | TypeScript | TSLint and your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files)

Note: please don't paste log content here, put it on some file server and provide a link

1
Comment actions Permalink

settings are fine, and there are no errors in log that look related.

Can you recreate the issue in a new project? Create a new default angule-cli application, enable TSLoint there - does the problem persist?

Also, did you try invalidating caches (File | Invalidate caches, restart)?

 

0
Comment actions Permalink

Still happens in a new project:

http://iforce.co.nz/i/xo35q1qy.uuh.png

 

Yes I have tried invalidating caches previously. I just tried reinstalling TSLint and Typescript and it still doesn't show. Wiping out my PHPStorm settings directory did nothing either.

0
Comment actions Permalink

From your screenshot I can see that class and method are red-highlighted in editor. Hover over the highlighted items - what errors are shown?

0
Comment actions Permalink

They aren't errors but weak warnings about unused functions/classes.

0
Comment actions Permalink

Does the path to your project contain a symlink or junction?
I had the same problem when opening my project from D:\some_junction\project_dir. Using D:\some_dir\project_dir solved it.

0
Comment actions Permalink

Wow, thanks Thojo!

Yes, my project is in ~/code/ which is actually symlinked from /mnt/1tb/code/. Opening the project from /mnt/1tb/code/ instead reinstated TSLint errors in the IDE. The next question would be is this a PHPStorm change that did this or TSLint?

0
Comment actions Permalink

It's a PHPStorm change - since 2017.1, TSLint runs as a language service (we used to run it via command line before).

Seems language service doesn't like symlinks/junctions. Please vote for https://youtrack.jetbrains.com/issue/WEB-27253

0

Please sign in to leave a comment.