can't close "Find in Path" dialog opened in split view



1. Have 2 split views

2. Open "Find in Path" dialog on Mac with ctrl + Shift + F

3. Try to close

It's not possible to close at all


can you get this fixed please 



Do you mean that clicking inside the editor doesn't close the dialog? 

What happens if you press ESC?

What IntelliJ IDEA version do you use?

Are there any errors in the log?


I tried closing by pressing ESC key but it doesn't closes it.

It'll be nice to have just "X" button on this dialog

I'm using 2017.1.3 version on Mac 10.11.6


Which log I need to view for errors ?




I got the log file but there is no way to attach here

Can't close by clicking outside dialog as well. Since last few days this issue has become more prominent, today I could reproduce it even in non split window


Feel free to attach to one of the related tickets in YouTrack linked above. YouTrack is the proper place for bug reports, this forum better suits discussions.


ok thanks for quick clarification.


Same serious wondering here. It is not pro or good practices approach to leave closing any form depend on "click somewhere else". I don't except that kind of toyish behavior in such high end product like Phpstorm.

There is reason for this. There is already too many broken software that leaves windows hanging open behind open windows. When I can not close window explicitly it always makes me wonder if it is open somewhere still. For >25 years of windows(and linux) desktop broken programs have left open windws under others . And they continue to do so. And now suddenly I am forced get that same feeling from phpstorm which have been my most beloved software. The other thing is that if you choose that kind of toy behavior it should be everywhere for every window. Which it certainly currently is not.

On the other hand if phpstorm had that "click somewhere else" behavior in every popup I would immediately abandon it.

I have to add here that windows metro style UI ideas are no good for such a program like phpstorm. It is complicated thing so it should be kept extremely simple. Now in intellij there can be seen bloating tendency with features. Intellij is on the road that most possibly finally kills phpstorm and friends because the most powerful marketing combat skill gets lost.

Which was UI clarity and easy step in.



MacOS Sierra PHPStorm 2017.3.6 here. This started happening recently:

  1. Cmd Shift F to trigger Find in Path
  2. Type the text
  3. 3 up/down to navigate to a match
  4. Enter navigates to the match in editor, and dialog loses focus

I think this is wrong because:

  1. While navigating matches using up/down I already see the context
  2. Dialog is left open - covering editor space (also leaving the impression that typing might happen inside the editor instead of messing with code behind the dialog)
  3. Dialog won't close on ESC because it lost focus

I think old behavior (where dialog just disappeared upon double-click or enter while match is selected) is superior for the 3 reasons. I can't see a single reason why dialog would stay visible.

EDIT: just realized I've accidentally pinned the dialog (upper right corner). I guess it can be useful on huge screens where dialog could be moved so it pops up without covering editor space - then it makes sense to stay on.


Try 2018.1.3 version, the way it works there is exactly as you describe.


Thanks - it was me ;) pls see the edit above. I was sure it was the old behaviour.


Same problem on GoLand 2018.1.5
Build #GO-181.5281.38, built on June 15, 2018
JRE: 1.8.0_152-release-1136-b39 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.4

 I just cannot close Find window. It doesn't react on Esc. WTF?!


@Vladimir can you describe the exact scenario when it does not work? A screenshot would be also helpful.

There could be some different scenarios, e.g.


@Andrey, would be happy to describe the way to reproduce it, if you would know how. The scenarios you have mentioned are ambiguous. Would be glad to repeat them if you can show me the video what should I do.

I don't know exactly how to reproduce the bug. For now I have reported bug


I found when I import settings from an old version. The 'Ctrl+F' dialog and the 'Find in path' dialog can not be closed by 'ESC'. I suppose there were some old setttings can not adjust the new idea version. For this problem, I reset my settings on the new IDEA version.


I solve it.  as shown in the screenshot.


Had same problem on windows, find in path closing only by pressing ESC key. Solved it by unchecking this "Pin Window" option.



Zcsunt - it works!!! Unbelievable that you have to explicitly bind escape to... escape 🤦🏻‍♂️
Thanks for the solution 🤜🏻  



Please sign in to leave a comment.