Mac OS. Webstorm 2017.1.4. Out of memory

Dump heapDump-Webstorm-1497421140900.hprof.zip

0
10 comments

Unfortunately the snapshot shows that only 60MB are used. It sometimes happens that auto-created memory dumps are slightly delayed and captured after memory was cleared. Please can you try taking snapshots manually using Help | Capture Memory Snapshot once memory usage becomes high?

CPU snapshots taken when IDE runs slow (https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems) and idea.log might also be helpful

0

WS-171.4694.29_out_of_memory_14.06.2017_15.09.31.zip

0

I am having a problem with out of memory and it's happening a lot, so much it's frustrating.  It's hard to get my work done.  It all started happening two upgrades ago.  I posted on the 2016 post for the same problem but I'm using the latest code:

WebStorm 2017.2.4
Build #WS-172.4155.35, built on September 11, 2017
JRE: 1.8.0_152-release-915-b11 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.6

I have uploaded my .hprof file you your HTTPS support server.

0

What is the file name?

0
I know I put my name on the file I uploaded.  Something like:
        java_error_in_webstorm-paul-boster.hprof
0

Try excluding the generated files (like templates.1506040381950.bundle.js) from indexing, by either marking the build target directory as Excluded or adding these files to Exclude files: list in Preferences | Directories - does it make things any better?

0

Also, looks as if the indexes are broken. Please try invalidating caches (in addition to excluding build output): File | Invalidate caches, Invalidate and restart

1

One of my co-workers suggested excluding the output directory.  I now exclude several directories and turned off some plugins I don't use.  I still see some slow downs and I saw an out of memory dialog again.

I just invalidated my cache and restarted.  We'll see how it behaves today.

0

Friday went well.  I'm crossing my fingers that excluding folders and invalidating the caches fixed it.

0

Please sign in to leave a comment.