Debugging node version 8.1.2

Hi,

After upgrading to node version 8.1.2 I'm unable to debug my project with Webstorm.

I get the following error:

/usr/local/bin/node: bad option: --expose_debug_as=v8debug

Any ideas?

 

12 comments
Comment actions Permalink

Debugging with Node 8.x is only supported in 2017.2. Please try the EAP build - https://confluence.jetbrains.com/display/WI/WebStorm+EAP

1
Comment actions Permalink

Works great. thanks

0
Comment actions Permalink

This did not work for me. Using node version 8.1.3 and 

 

WebStorm 2017.2 EAP
Build #WS-172.3198.20, built on June 29, 2017
WebStorm EAP User
Expiration date: July 29, 2017
JRE: 1.8.0_112-release-736-b21 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.5

 

I get the exact same error as OP. 

0
Comment actions Permalink

please attach a screenshot of your run configuration. Most likely, the Node.js version can't be detected correctly. Do you use babel-node as interpreter by chance?

0
Comment actions Permalink

After posting my comment I found this issue: WEB-27303 which seems related to my problem. I guess build 3308 is due later today, which according to https://youtrack.jetbrains.com/issue/WEB-27303#comment=27-2293963 should provide a proper workaround. 

 

 

 

1
Comment actions Permalink

I see. You should have mentioned that you are using React Native.

Debugging React Native with Chrome runtime will be included in next 2017.2 EAP

0
Comment actions Permalink

Has remote debugging been updated to support the inspector protocol as well? I'm unable to connect to a remote process, while both VSCode and Chrome are able to.

0
Comment actions Permalink

Node.js Remote run configuration can only be used when debugging with TCP-based Protocol (Node.js < 7.x).

To debug application with Chrome Debugging (inspector) Protocol remotely, you need using Chromium Remote run configuration

 

Note that this doesn't work in 2017.1.x, https://youtrack.jetbrains.com/issue/WEB-27559 is fixed in 2017.2

0
Comment actions Permalink

Worked for me after adding --inspect to "node parameters" field inside Node debug configuration window. Though it throws a deprecation warning for --inspect-bark parameter but works. 

(node:40389) [DEP0062] DeprecationWarning: `node --inspect --debug-brk` is deprecated. Please use `node --inspect-brk` instead.

https://github.com/nodejs/node/issues/13564

2
Comment actions Permalink

@Elena, Thanks! Chromium Remote worked for me, however naturally people choose Node.js Remote over Chromium Remote when creating a debug config.

I can see how this could cause confusion.

0
Comment actions Permalink

@Sam, in 2017.3, these configurations will be replaced with a single Attach to Node.js/Chrome configuration:

 

this will probably help to avoid the confusion

0
Comment actions Permalink

Ivemerod solution worked for me.

0

Please sign in to leave a comment.