editor background color by scope not working?`

I'd like for test files to have a different background color in the editor. I know the scope is working because the tab is the color I want for test files.

But when I go to Editor/Color Scheme/By Scope and try to set that up I can't get anything scope dependent to work.

I have everything checked in Appearance&Behavior/File Colors although I don't think that is related to my issue. Other than that it does show the scope is working.

PS.

As an aside, I don't think there is any menu alternative or setting to set the editor background picture. You have to use Ctrl-Shift-A to find it. This is no problem for me because I don't plan to use it. But I found it as part of trying to get the editor background colors to work and thought I'd point it out in case it isn't on purpose.

1 comment
Comment actions Permalink

PhpStorm 2019.2.3
Build #PS-192.6817.20, built on September 25, 2019
Licensed to ***
Subscription is active until October 30, 2019
Runtime version: 11.0.4+10-b304.69 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 7 6.1
GC: ParNew, ConcurrentMarkSweep
Memory: 984M
Cores: 4
Registry: run.processes.with.pty=TRUE
Non-Bundled Plugins:

File | Settings | Editor | Color Scheme | By Scope 

jetbrains://PhpStorm/settings?name=Editor--Color+Scheme--By+Scope

Color scheme: Default

There is no visual difference after changes.

Documentation https://www.jetbrains.com/help/phpstorm/2019.2/configuring-colors-and-fonts.html doesn't have any information about this feature.

 

0

Please sign in to leave a comment.