Coverage not showing in RubyMine

Answered

The coverage results are not showing when I'm running the tests with coverage. I have simplecov specified in the Gemfile and have "require 'simplecov' SimpleCov.start 'rails'" specified in my test_helper.rb file.

All the coverage-results are available in the "coverage" folder, but I want the results to show directly in my IDE.

Any ideas why this is not working? Is it possible that another gem is "blocking" the coverage generation in RubyMine?

I'm using RubyMine 2017.1.4.

 

Thanks!

7 comments
Comment actions Permalink

Hello, could you please detail what do you expect to see in IDE? coverage report should be open in coverage tool window. Are you able to see it after tests are finished? Please see more in help topic: https://www.jetbrains.com/help/ruby/viewing-code-coverage-results.html?

0
Comment actions Permalink

I expect to see information in the project view (for instance: 100% files, 98% lines covered). I also expect to see green and red markings in the editor to show which line is being covered by some tests. (See image).  When I run my test nothing happens. I can only see the test results in the Console. Each test is doing some transactions against my actions in my controllers, and I'm also using fixtures. What's strange is that I can see the "index.html" file being generated in the "coverage" folder, so something is working. I just want to see the results directly in my IDE.


0
Comment actions Permalink

Thanks for the screenshot, looks like coverage report in Editor is not shown for some reasons. Could you please update until 2017.1.5 and try again. If it doesn't help please attach idea.log (Help | Show Log in...).

0
Comment actions Permalink

Tried updating to 2017.1.5, but still no coverage report. Also tried to update to 2017.2, but then the tests wouldn't run so I downgraded to 2017.1.5 again.

The idea.log can be found here: https://pastebin.com/xeFusKLf

 

Since the tests are running using SSH, could it be that the IDE have problems finding the generated coverage file because of that?

0
Comment actions Permalink

Sorry for such long delay, are you still experiencing this problem? If yes, please attach your settings.jar (File | Export Settings...) and idea.log (Help | Show Log in...) again.

0
Comment actions Permalink

Hi, it appears the bug is still present. I'm also using ssh for remote development (remote ruby sdk).

0
Comment actions Permalink

Hi Paweł,

running coverage with remote interpreters isn't supported yet, please vote for the corresponding issue on our tracker:

https://youtrack.jetbrains.com/issue/RUBY-12337

0

Please sign in to leave a comment.