Stop annoying cmake window popping up everytime I modify a CMakeLists.txt


Everytime I make a modification to a CMakeLists.txt file, on the bottom a panel pops up as it's reloading the cmake. Obviously it needs to do this when I make a change, but is there any way I can have it do so without popping up that annoying window? Since I have auto-reload turned on, if I have 10 lines to add to my cmake file it constantly reloads while i'm trying to make a change, and since it takes up a decent portion of my screen I keep closing the window, but as I keep typing it just keeps popping back up and is really frustrating. 

I have tried to find an option in View/Winow menus to hide the window permanently but I haven't found anything. Please help...



Could you minimize the bottom window? (by clicking the minimize button on it or disabling checkboxes in "Window | Background tasks") Also, you can disable autoreload if you wish (via "File | Settings | Build, Execution, Deployment | CMake - Automatically reload CMake project on editing").


I do minimize the bottom window, but when I make a CMake change it reloads and pops the window back up. I could disable auto-reload, but I like having that since i'm frequently making CMake changes it would pop backup again when I manually tell it to reload the cmake changes. I understand the reloading is necessary, but I really wish there was an option to permanently hide that window.


I am having this issue as well.


Additionally, I've turned off auto reloading, but the "CMake project needs to be reloaded" keeps popping up and any time I make a change to the file the ide hangs for about a full second or two and then the yello "project needs to be reloaded" comes back - the auto reloading is far, far too aggressive. 


I tried turning off every single autosave feature in the ide, but it's still showing up - this is obnoxious and more distracting than helpful. At least give me an option to wait until I manually save save let file before beginning the reload check!


Hello Jlack1987 and Dwood15!

Sorry for the late response. I've created the issue in our tracker about an option to hide the "CMake project needs to be reloaded" notification: Also we have the issue about increasing auto-reload timeout when CMake file is being edited continuously to avoid constant reloads: Feel free to comment or upvote the issues, follow them to get updates.




I was also facing the same issue and I resolved by doing following:
In your project directory there is a file workspace.xml in folder .idea/
In this xml file you can set 
 <component name="CMakeSettings" AUTO_RELOAD="true">
 <component name="CMakeSettings" AUTO_RELOAD="false">
Or even you can simply keep it like this : 
 <component name="CMakeSettings" >

Hopefully, this might help.
Kind Regards,
Bilal Ahmad Butt


Hi Bilal!

<component name="CMakeSettings" AUTO_RELOAD="true">

It's auto reloading, you can turn it off in the CMake settings: `File | Settings | Build, Execution, Deployment | CMake` > disable "Reload CMake project on editing <...>".


Hi everyone!

There seems to be a confusion about auto reload here.
If I understand properly what Jlack1987 is saying, the problem is not about auto reload occurring often, but that each time it does the bottom panel is brought up.

Auto-reload is fine, but it should be happening in background. I have the issue my self when I'm using the integrated terminal: I'm typing some git commands or anything else, and when I do, I often loose focus and end up writing in my source files because of this panel appearing.
A simple notification somewhere should be enough to notice user that the auto-reload has been triggered.

Could you at least add an option like “Show CMake panel when an auto-reload is triggered: YES/NO”?

Thank you,


Please sign in to leave a comment.