[Windows 10] Annoying external monitor scaling

Answered

Two days ago I updated my RubyMine and WebStorm installs to the latest version (v2017.2) and immediately had issues with scaling on my external monitors. My laptop has a 4k screen and I use twin full HD external monitors. Normally when I slide an app window from 4k --> Full HD the window and fonts shrink appropriately and the reverse happens going the other way.

I thought I did something wrong before I updated or applied some weird software/system setting so I looked at my preference settings and I played around with my monitor resolutions and scalings. Nothing made the apps appear the way it did before the update. I uninstalled the software and downgraded to the previous versions (v2017.1.x) and it worked again!!!

Has anyone else seen this behavior? Have you been able to figure out why it happens and what you did to fix it?

System info:

  • Toshiba Satellite S55t 4k
  • Windows 10 Creators Update
  • Asus VN248H-P
  • StarTech USB3 dock USB3SDOCKDD
2 comments
Comment actions Permalink

Hi, unfortunately this is a known issue. Please try this trick from user: https://youtrack.jetbrains.com/issue/IDEA-141456#comment=27-2327776.

1
Comment actions Permalink

I updated Webstorm to 2017.2.3 and got the same issue. I tried my IntelliJ and don't have this issue. Any resolutions?

0

Please sign in to leave a comment.