2017.2 update running out of memory while indexing project

Answered

After doing last update, when I try to open 2 projects, the program starts running out of memory while indexing, even having 8GB of RAM, the problem is that I can't set it to use more memory, because of the indexing task that locks the window from responding.
I'm considering to downgrade to 2017 1.4, where I could open up to 4 projects simultaneously.

 

33 comments

Same here.  And yes, this sucks.

If you kill the application then you can manually modify the phpstorm64.exe.vmoptions file and then restart Phpstorm.

Update -Xmx field:

For me, I set mine to 1500 mb

-Xmx1500m

However, if you get the application running prior to loading a project, you can use Help/Diagnostics/Change Memory Settings.

Good luck.

5

Thanks a lot Marshall, I did what you said, changed memory settings to 1500 and now it's running smooth! ;)

0

Thanks Marshall - this saved me a lot head scratching.  +1

Help/Diagnostics/Change Memory Settings - was on 750 now on 2048 :-)

0

Getting this a lot all the time now. Before 2017.2 I never had any issues. I've re-installed PhpStorm from scratch and removed all custom plugins, as well as removed the `.idea` folder from my projects, but always get hit with this error now on a regular basis.

0

Another suggestion is to "Exclude" those directories that you do not wish to have indexed.  This is potentially helpful with larger projects.  Under Preferences/Directories you can set "Excluded" resources.  As I understand, the excludes are not indexed.

For me I like to keep all of my relative development items within my project tree but they are irrelevant to my source code and I don't need them indexed.  Things like graphic file sources and nix scripts.  The editor doesn't need to know anything about these.

0

Why on Earth does indexing lock up the UI anyway?

0

Does it completely block UI for you (e.g. total application freeze)? Indexing utilizes all CPU available - that's why IDE works sluggish on indexing

0

I increased the memory to 2048MB but still getting this error! What can I do?

1

Trying the latest 2017.2.4 - the same, even worse - after installation I created a project with only 2 php files. Opened Settings and it started this Out of memory errors.Complete rubbish!

Also it increases its memory consumption (through task manager) to over 1.5GB before this happens. And after reading this thread, it seems this happens for many months with all 2017.2.x versions! Totally unacceptable.

0

I concur.  This should have been fixed a long time ago.  I am reluctant in renewing my license because of issues like this...

0

After a clean install of 2017.2.4 (first uninstalling and deleted all jetbrains folders everywhere), it seems to run Ok for now and I couldn't reproduce the problem for now. The CPU is idle in settings dialog also (before, it loaded CPU 30-40% constantly while in Settings). Also now the memory doesn't climb when in Settings.

Before that, nothing from methods described here and there have helped (for example cache cleaning/restart etc.). There must be some big problem in importing settings from previous versions. Not sure if this is the solution, but it seems one has to go through the LENGHTY process (hours) of setting up everything from scratch. I have no words to describe what's on my mind now!

0

Teo Teo, thanks your efforts.  Your post sparked a memory and I recall doing the same with another project.  I will say that this is still one of the best editors I have used and I have spent a great deal of time and $$ on many of them.  I have had issues with them all.  Please keep us updated.

0

@TeoTeo 

> Trying the latest 2017.2.4 - the same, even worse - after installation I created a project with only 2 php files. Opened Settings and it started this Out of memory errors

 

Were you by any chance on a "Fonts" settings page? 

Could you please share your idea.log file (Help > Show log in ...), e.g. upload to dropbox, google drive & share the link?

0

I was testing in virtual machines, relatively freshly installed Windows's. I gave up for now and will continue with the process later. I deinstalled the testing installation.

But yes, I happened to notice this behavior mainly when "rounding" the fonts pages. Also, again, after installing cleanly, I couldn't reproduce the problem, even clicking intensively the Fonts pages and other pages in Settings. But for now this is not feasible in principle - to set up everything from scratch.

Thanks.

0

Same issue with RubyMine.

Installing the latest 2017.3.rc fixed the issue that I had with 2017.2.

 

Thanks

0

Same issue, with 2017.3 I must set to 8192M to make the -Xmx error message disappear.

 

0

Me too.

After upgrading (when prompted by the update checker) PhpStorm from 2017.2.4 to 2017.3 -- 750Mb was working fine before, now had to raise the limit to 2048Mb in order to make the error go away and to be able to open previously working project.

0

2017.3 appears to be working fine with my settings from 2017.2x  (1500mb).  No problems yet.

0

It was only the first start after upgrade I had the problem, once the project was succesfully opened by the new version, it works even with original 750Mb setting.

0

Nice to hear.   Fingers crossed that JB got the memory issues resolved.

0

Happend to me too. 2017.3

I have some many-GB-files in my project-folder (ignored by git). After upgrading to 2017.3, I was unable to open project. I tried to increase -Xmx to 3GB but it did not work. I had to move the big files out of the project folder to make it work...

0

Morten, please submit a support ticket attaching your logs (Help | Collect and Show Logs in ...). https://intellij-support.jetbrains.com/hc/en-us
This thread is kinda outdated.

0

Try File > Invalidate Caches / Restart

Increasing the memory and excluding directories did not help my case. There might be an issue with the existing index so try clearing the cache and reindexing.

1

I just got bit by this on my Linux Mint laptop (4g memory). I upgraded from 2016.3 to 2017.3. I get these incessant memory Xmx errors. Nothing seems to fix it. And is it ever slow. System monitor shows java at 200% (2 cores maxed out) while it is trying to figure things out. 

<Linux mint01 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux>

I reverted back to 2016,3 for now. I feel good about showing that off. Not so good about about 2017.3.

Oh. No issues thus far with my Windows 10 laptop and 2017.3. It has 16g and ssd.

0

This is happening to me now as well. It's not even a big project. When will this be fixed?

 

0

Out of memory errors should be investigated individually in most of the cases. It would be great if you could contact us via Help > New Support Request.

This way we'll be able to check your setup, heap files in a more convenient way rather than pasting them here or uploading publicly. 

0

I was able to clear this error by replacing the .idea directory with a backup from the day before the error appeared. Apparently, one or more of the settings files were corrupted.

 

2

just ran into this problem today - increasing -Xmx to 2048m did not work - i finally moved the .idea directory out of the project and reloaded the project from the iml file - this finally allowed IDEA to startup

given the number of people talking about this, Jetbrains, you have a problem that is more than just any individual system/setup/configuration and you need to fix it, especially since you're milking us monthly now for subscription fees

0

Almost the same problem here with IntelliJ Ultimate 2017.3. After a few minutes of having the project open, the OOM Error is thrown.
Never had any trouble working in our project. Yesterday I had our current project (git) and our old project (svn) open at the same time. After that everything went downwards.
- cleaned the cache 
- wrote vcs.log.index.git=off into custom properties
- freshly checked out the .idea folder from git
- assigned 4096 MB to IntelliJ
- removed all projects from IntelliJ history
All that did not work unfortunately. 
Just removing the .idea folder completely seemed to help. But then one can not really use IntelliJ.
While checking the heap dump I noticed a tremendously large int Array being created by some instance of a  Fork...class  (I unfortunately deleted the dumps because I thought I had the problem solved)
EDIT: Currently installing 2017.2.6
EDIT2: Took another look at the heap dump. A leak suspect might be is com.intellij.concurrency.IdeaForkJoinWorkerThreadFactory retaining 360 MB of 450 MB heap space

0

Please sign in to leave a comment.