webStorm 2017.2 UI Fonts and Icons Much Larger Than Before

I'm on Windows 10. Friday the IDE was fine. Today (Monday) the Editor and UI fonts were much larger than before. I was able to reset the Editor font, but the UI is still too big.

4 comments
Comment actions Permalink

do you have Override default font enabled in Settings | Appearance & Behavior | Appearance? If yes, try disabling it to revert to default font and restart the IDE - does it help?
If it doesn't, can you check if passing -Dsun.java2d.uiScale.enabled=false VM option to WebStorm (this has to be done in *.vmoptions file, Help > Edit custom VM options) makes any difference?

0
Comment actions Permalink

I used the Appearance & Behavior > Appearance > UI Options > Override default fonts by (not recommended):

Set it to Sergoe UI, Size 12.

The line height could be adjusted, but it looks OK for now.

I should mention the splash screen also looks bigger than it was before.

Thanks,

- AAA

 

0
Comment actions Permalink

Thanks for the reply Elena. No, it wasn't checked. I added the check to correct the issue.

Added the vmoptions line, and it corrected the issues. Had to take off the Override default font checkbox, and resize the Editor font. All better now.

Also, the splash screen is back to normal.

Thanks again,

- AAA

 

 

0
Comment actions Permalink

Adding the VM argument also fixes this issue for intellij idea 2017.2.1

Additionally I still had to set the font size in Settings | Appearance & Behavior | Appearance and I also set the editor font size in Editor | Font to make things to my liking.

0

Please sign in to leave a comment.