New SQL File Per Query

Hi,

I am connecting to PostgreSQL and Redshift successfully. Once I have run 1-2 queries on the console (or any other command such as CREATE TABLE), I get the following error (COMPANY used to replace the name of the company): 

[HY000][500150] [COMPANY](500150) Error setting/closing connection: Not Connected. java.lang.RuntimeException: com.COMPANY.support.exceptions.GeneralException: [COMPANY](500150) Error setting/closing connection: Not Connected.

When I create a new SQL file, and paste the same code, it executes. And then the situation repeats itself.

Is there a bug with the software?

Thanks! 

7 comments
Comment actions Permalink

The first link solution provided is not clear as to where to append the URL. I experimented nonetheless, but had no luck.

The second link solution I tried, successfully added Redshift as shown in the instructions, but the problem persists. 

Thanks! 

0
Comment actions Permalink

Hi,

To add parameters in URL you need to switch to URL only mode:

Thank you.

0
Comment actions Permalink

Unfortunately I do not have this option / dropdown. I do have the URL and did add /ssl=true&sslfactory=org.postgresql.ssl.NonValidatingFactory but it says its an invalid operation. 

0
Comment actions Permalink

Hi,
>>Unfortunately I do not have this option / dropdown.

Which one? Could you provide a screenshot?

Also, pay attention to our help https://www.jetbrains.com/help/datagrip/2017.2/connecting-to-a-database.html#amazon_redshift

Thank you.

0
Comment actions Permalink

Ah ok you added Amazon Redshift :)
I got to step 3 and then got an error when I clicked Download missing driver files:
Failed to download 'http://download.jetbrains.com/idea/jdbc-drivers/redshiftjdbc42-1.2.1.1001.jar':
Status: 403

When I manually add the driver into Amazon Redshift, I am able to connect. 

However, when I append "ssl=true&sslfactory=org.postgresql.ssl.NonValidatingFactory" to the end of my URL I get the same error as before: 

Connection to aws-rs-mycluster failed.
[3D000][500310] [Amazon](500310) Invalid operation: database "mycluster/ssl=true&sslfactory=org.postgresql.ssl.NonValidatingFactory" does not exist;

Any ideas on what I can do? 

0
Comment actions Permalink

 

[duplicate post]

0

Please sign in to leave a comment.