Cannot install ruby-debug-ide due to external dependencies

  • Winodws 7 32-bit (VM)
  • Ruby 2.1.4
  • Latest version of gem
  • RubyMine 2017.2

Installed RubyMine today.  Tried debugging and RM attempted to download the required gems (failed because I had not provided proxy information at the time). Decided to install manually:

  • Successfully installed and tested DevKit (mingw64-32-4.7.2)
  • Tried installing ruby-debug-ide. Error: Unable to resolve dependency: user requested 'debase (> 0)'
  • Tried installing debase. Error: checking for vm_core.h... no (listed 3x)

Looking at the mkfm.log that was created, it too states that there is no file by the name "vm_core.h".

Did some Googling and found some people had success after installing debugger-ruby_core_source.  This was installed successfully, but the trying to install debase or ruby-debug-ide still fails.

I'm out of ideas at this point.  Any help is appreciated.

 

3 comments
Comment actions Permalink

Hello, could you please attach idea.log (Help|Show log in Explorer)?

0
Comment actions Permalink

I don't see a way to upload a file to this post.  Our corporate firewall does not let me go to sites like pastebin or GitHub gists.  Do you want me to paste the contents of the file here?  Its about 110KB of text.

0
Comment actions Permalink

After reading your support FAQ, I have sent the file to intellij-support@jetbrains.com.  Thanks.

0

Please sign in to leave a comment.