RubyMine doesn't highlight erb code

After installing the latest RubyMine build (I was using probably a 3 year old build before), the editor no longer formats and highlights erb code -- it just displays it as raw text.

Strangely enough, if I create a brand new erb file and manually type code in there, it works. But if I copy and paste my existing code into the new file, it doesn't work either. 

I tried renaming the file to just .html, then back and forth, still no luck. I tried deleting the .idea folder, still no luck. I triple-checked the 'File types' for RHTML, and even removed *.erb and re-added it, closed and relaunched RubyMine.. still no luck.

Please help!





could you please specify whether you've performed an update or installed from scratch the new version? In addition, would it be possible to provide your settings (File | Import Settings)? You can send me them to


Hi Olga, 

I'm having the same problem with my download of RubyMine (2017.2.1). I actually had this problem with a previous version (when perpetual licenses were still allowed), but now I have no code syntax highlighting for neither .rb or .erb files.


Olga, I sent the settings over to the email provided. Also, I installed it from scratch, not an upgrade



You should give this Stack Overflow post a try ( I followed those instructions and the code syntax highlighting is now working for me.


Hmm, I installed Rubymine from scratch on a brand new machine, so I can't imagine there would be left over configuration files...


Please sign in to leave a comment.