PhpStorm: option to *not* copy deleted line of code (shift+delete) to clipboard?

If I delete a line of PHP using shift+delete, the deleted line is copied to the clipboard. This can be annoying, especially if you want to preserve the clipboard contents for another task.

Is there a way to avoid this happening?

1 comment
Comment actions Permalink

Hi there,

Well .. for me on Windows using Default keymap ... the Shift+Del shortcut is the same as Ctrl+X (Cut). That explains such behaviour.

So .. either use just Del .. or remove Shift+Del from "Cut" action (and assign to another one if needed).

Shortcuts can be viewed and altered at "Settings/Preferences | Keymap"

P.S. In addition to search field (which allows you to find action by its name) .. there is also "magnifier" icon next to it -- use it to find what actions have specific shortcut assigned to them (search by shortcut).

0

Please sign in to leave a comment.