RubyMine 2017.2.1 typing lag in 4k display

Updated one monitor to a 4k monitor But there is a terrible typing lag in RubyMine.

Every character that i typed, i had to wait a bit for RubyMine to react. However, this only happen in my 4k display but not the 1080p. Everything work perfectly in the 1080p monitor. In addition, It doesn't seem to be memory related as the memory is that high in the memory indicator. I searched around for solution, came across with dhidpi setting which i tired and didn't seem to do much. I was wondering if there is any other way to improve this experience cuz it's really painful to develop with this typing lag. I don't want to have to go back to a 1080p monitor

Thank you so much.. see the following for the spec of the things that I am using 

My RubyMine version is 2017.2.1 build #RM-172-3544.29

My setup:

  1. 15" MacBook pro 2016 with touch bar
  2.  2.6 Ghz i7
  3. 16 Gb Ram 
  4. Samsung u28e590 28" 4k display
  5. Asus VN248 24" 1080p display 
3 comments

Thanks for bug-report, this is a known issue:( Please vote for https://youtrack.jetbrains.com/issue/IDEA-144261.

0

I found something like that but it was from 2015. It's been a couple year and 4k monitor start getting cheaper. Figured you guys have fixed it already...

But is there anything i can disable to improve the quality of life ?

0

Please sign in to leave a comment.