Terminal stuck in window mode

Answered

So I use the embedded terminal a lot, and yesterday I clicked "Windowed Mode", however I hate it in window mode and I cannot for the life of me figure out how to put it back at the bottom. 

 

I'm using the most recent PhpStorm EAP on windows 7. And here is a screenshot posted below, any ideas how to put the embedded terminal back?

 

5 comments
Comment actions Permalink

(Reposting my Twitter reply) There should be an icon left to the Hide icon. Is this area clickable? http://prntscr.com/gbmud4

If it's not, you can change WINDOWED to DOCKED in .idea/workspace.xml for id="Terminal". But it's still necessary to understand what happened to the icon.

0
Comment actions Permalink

Clicking the window mode again again in the settings dropdown brought the terminal back to the bottom on Phpstorm like normal!

 

Thanks for the help!

7
Comment actions Permalink

I have encountered the problem of collapsing docked windows as well lately. It is a real struggle to get them to dock in the right place again, I agree.

0
Comment actions Permalink

That is not intuitive! In the menu under "Window > Active Tool Window" the option for Docked mode was even grayed out. "Unselecting" windowed mode did the trick.

Please change this!

1

Please sign in to leave a comment.