IntelliJ 2017.2.2 : constantly freezing in a Symfony project.

Answered

Lock solid. I need to kill using xkill or the command line.  Constantly happening since the last update. It happens in twig files, php files, it doesn't seem to matter. It's unusable. Please tell me the latest and greatest ways to get the information together that you need to find out why this is happening. My development is stalled. Many thanks. (It's happening under Debian Stable BTW).

9 comments

I found the issue. I believe it to be an IntelliJ bug.

I have a symbolic link in my /web directory to a filesystem containing hundreds of thousands of images in a hash based path hierarachy. As soon as I remove the symlink IntelliJ can then close/continue. Note that my /web directory IS marked to be ignored.  I had a twig file open with asset links to my top level images directory. The first image is "all ok", the second image shows the setup where IntelliJ freezes. Note that it froze when I closed the project a short while ago and spring back to life when I removed the "person" symlink from a command prompt. 

(1) OK

(2) Not ok : symlink to huge img repo:

 

0

What is a registry property? It mentions right at the end 

 

In IDEs with version 2017.2 and later there is registry property not to follow symlinks for indexing 'indexer.follows.symlinks'. The registry value should be set to 'false'
 
I can't see anything in my settings. Can you point it out to me please. But more to the point why is it indexing a directory in an ignored directory?
 
0

Ignored directories can be indexed if they are referenced from the libraries.

Help | Edit Custom VM Options, add -Dindexer.follows.symlinks=false.

0

Added and restarted. Recreated the symlink. Same issue.

 

(1) Frozen

(2) deleted the symlink it comes back to life.

0

I have created a bug and linked to this thread. As stated above this suggestion does not fix it.

0

 

I googled some more:

https://intellij-support.jetbrains.com/hc/en-us/community/posts/208004749-Freeze-after-last-update-

 

Turing on "Power Save Mode" I can work:   a "temp fix". It seems this is an ongoing issue. my VM options file:

 

idea64.vmoptions

 

# custom IntelliJ IDEA VM options

-Xms128m
-Xmx750m
-XX:ReservedCodeCacheSize=240m
-XX:+UseConcMarkSweepGC
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-Dsun.io.useCanonCaches=false
-Djava.net.preferIPv4Stack=true
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow
-Dawt.useSystemAAFontSettings=lcd
-Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine
-Dindexer.follows.symlinks=false

 

 

0

Please sign in to leave a comment.