Timeout waiting for response on 113 when using Pycharm?

Answered

I am using Pycharm Community edition and I am getting "Timeout waiting for response on 113".

 

How can I get rid of this issue?

 

 

10 comments
Comment actions Permalink

Could you please attach a screenshot that shows the issue? Thank you.

0
Comment actions Permalink

I am facing the same problem while debugging Django project with PyCharm.

Unfortunately, I am unable to find the root of the problem, because PyCharm is able to debug empty Django project without any problems. All I have found is that it freezes after importing the main project module:

# django/apps/config.py:195
def import_models(self):
# Dictionary of models for this app, primarily maintained in the
# 'all_models' attribute of the Apps this AppConfig is attached to.
self.models = self.apps.all_models[self.label]

if module_has_submodule(self.module, MODELS_MODULE_NAME):
models_module_name = '%s.%s' % (self.name, MODELS_MODULE_NAME)
self.models_module = import_module(models_module_name) # freezes after importing main application on this line

Despite that I have not found the main problem, I have found a workaround. After installing the latest PyCharm version it suggests me to install cython debugger extensions. Though after pressing "Install" it fails with "Error creating textual authentication agent: Error opening current controlling terminal for the process (`/dev/tty'): No such device or address" error (this might be due to my local configuration issues), I am able to install extensions from the command line (please note, that it also uses some environment variables, you may find them here: github): 

sudo python /opt/pycharm-professional/helpers/pydev/setup_cython.py build_ext --inplace

After that, the debugger no longer freezes. So that, the problem might be related to Cython, not Django.

> PyCharm 2017.2.3

> Build #PY-172.3968.37, built on September 1, 2017
> JRE: 1.8.0_152-release-915-b11 amd64
> JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
> Linux 4.9.52-1-lts

0
Comment actions Permalink

A command for Mac users:

python /Applications/PyCharm.app/Contents/helpers/pydev/setup_cython.py build_ext --inplace

0
Comment actions Permalink

Hi.

I have the same bug in newest PyCharm 2019.2.

@Usman4839  @Andrey Kuchev


Because of this issue I rolled back to PyCharm 2018.1 where this bug is not present.

3
Comment actions Permalink

@Adam

Please file an issue to https://youtrack.jetbrains.com/issue/PY and provide idea.log file from Help | Show Log in... along with a screenshot showing the issue. We will investigate it.

0
Comment actions Permalink

I have the same problem as @Adam with PyCharm 2019.2. After downgrading to 2019.1, the problem was solved. 

In my case, I am using MxNet, which can do asynchronous computation in the background. When reading the values of MxNet variables (which might not be immediately available, and the problem need to wait until the computation for that variable is done), the problem happened. The problem happened only with 2019.2.  

 

2
Comment actions Permalink

This seems to be a complex issue, which needs to be investigated more deeply. So let me repeat Sergey's suggestion to submit a bug report to our issue tracker.

0
Comment actions Permalink

I have the same issue, I have open a new case on your issue tracker. Ticket ID is: https://youtrack.jetbrains.com/issue/IDEA-226015

1
Comment actions Permalink

I have the same issue when I am trying to Evaluate Expression while debugging. I have a PyCharm 2019.3.2 (Professional Edition). It would be fine to have an adjustable timeout parameter in Settings.

0

Please sign in to leave a comment.