2017.*.* hanging all the time where version 171.* does not

Phpstorm consistently hangs in between key presses.

The same project does not hang in the previous (none 2017) version.

The CPU snapshot is: PS-172.4155.25_skn3_07.09.2017_18.34.18.zip

9 comments

It tends to happen increasingly as phpstorm is left open longer. You can definitely notice the hanging/lagging on a fresh restart, but it gradually gets worse.

Invalidating caches only works partially and then after a while things go back to how they were.

0

Unfortunately there's nothing abnormal in CPU snapshot attached. You can try to capture it again but reproducing the issue for 2-3 minutes instead.

 

Is it a project located a local storage? Did you try to check performance with all custom plugins disabled?

 

Is it possible to share/send privately the project?

0

Here is a new longer capture:

PS-172.4155.25_skn3_08.09.2017_15.42.58.zip

The lag happened 3 or 4 times during this capture.

The project is stored on local hard disk.

I have followed various stackoverflow/forum posts that detailed what to disable/enable for performance. I did this in a prior 2017 beta dot version. It made a slight difference but it was only temporary, the end result was always intermittent 2-10 second lag while typing.

Unfortunately I can't share the entire project as it is our complete framework!

Is there anything else I can do to try and help?

Turning battery saving mode on seems to help, but of course this is then disabling most of the good reasons to use an IDE. Also the fact that this doesn't happen in versions prior to 2017 would imply that there is some bug introduced.

Unfortunately for me nodejs debugging in prior 2017 is painfully slow to inspect objects, so I cant rollback to that. I am stuck between slow debugging or slow typing!

0

The lag can even happen when not typing, so for example I switched back to phpstorm after making the above comment. Naturally I had not been focused on phpstorm for a while because I had chrome focused. Phpstorm seemed to be in a "lag" so I clicked the Tool menu. It took about 5-10 seconds to respond.

0

Thanks for a new snapshot. Issue seems to be caused by JS subsystem. I would suggest to submit the same report to our bugtracker for responsible developers to investigate.

0

>  for example I switched back to phpstorm after making the above comment. Naturally I had not been focused on phpstorm for a while because I had chrome focused. Phpstorm seemed to be in a "lag" so I clicked the Tool menu. It took about 5-10 seconds to respond.

Do you have some build tools running? Please try excluding all folders with files dynamically generated by build tools from project (Mark directory as/Excluded in folder right-click menu). Also, please try disabling "Unused global symbol" inspection in Settings | Inspections | JavaScript | General.

0

My only build process is webpack but this is currently disabled.

I just tried disabling this inspection for unused global, but immediately the same lag occurs.

I have posted to the bug tracker.

Anything else I can try?

0

Let's switch to bugtracker: it's easier to share data there + multiple engineers/developers would be able to see it

0

Please sign in to leave a comment.