PHPStorm Frozen

I had 3 projects open when phpstorm was updated to 2017.2.3. Now when I open phpstorm, it opens the same three projects and I am unable to get it to respond to any of the menus. I am using windows 10 and the projects are Vagrant boxes. Only one of the boxes was up.  I have been using PHPStorm for a number of years but this has never happened. I tried to uninstall and reinstall, but it did not help all is the same --FROZEN. I left it up five hours, because it says it is indexing, but there is no progress. 

3 comments

Do you mean that you have a project with 2 projects attached in a single IDE instance? Or 3 separate IDE windows?

0

There were 3 separate windows open in the IDE. I fixed the problem by shutting phpstorm down and moving two of the project directories, that were open in separate windows, to a directory that phpstorm was unaware of and then restarting phpstorm. It indexed the one project remaining and then worked properly. 

The problem was that phpstorm froze with the windows open and I could not kill them individually. The whole phpstorm system was frozen and I had to use "end task" in windows to kill them. All three windows opened every time phpstorm was restarted.  

 

0

Are the projects located at some sort of a network location (mapped disk or share)?

0

Please sign in to leave a comment.