Auto complete do not use Stylus syntax

We use Stylus a lot and we prefer the clean syntax Stylus has than the syntax SCSS has. We have used a lot of Sublime Text before we tried PhpStorm now, and Sublime Text writes Stylus so nice and easy!  

1.  When I write a property for example "pos" in PhpStorm it auto completes those three letters to position: absolute; instead of clean Stylus syntax position aboslute. In Sublime Text it would auto complete with correct Stylus syntax. We do not want to write position: absolute; because if we would like that we would have used SCSS instead of Stylus. How do we change so that PhpStorm auto completes with stylus syntax instead of CSS/SCSS syntax when we write Stylus in a Stylus file?

2. In Sublime Text when we write Stylus and have just finished writing a value, and hit 'enter' twice it would result with a new line without an indent but with PhpStorm when I hit 'enter' twice then it results with a new line with an indent which is not what we want because we hit 'enter' twice because we want to start write another class name. This does not make any sense in PhpStorm. Look at the examples below.

 

In Sublime Text when we hit 'enter' twice after writing a value

.class
color blue
background black

|

 

In PhpStorm when we hit 'enter' twice after writing a value

.class
    color blue
    background black

    |

 

As you can see we have to do a revert tab before we can begin to write a new class. How do we make PhpStorm behave more like Sublime Text when we write Stylus code?

Thanks a lot in advance!

/New PhpStorm user who uses Stylus a lot

3 comments

1. please follow https://youtrack.jetbrains.com/issue/WEB-15575 for updates

As a workaround you can try removing semicolons from live templates in Settings | Editor | Live Templates | Zen CSS

2. this can't be configured; please feel free to file a feature request to youtrack, https://youtrack.jetbrains.com/issues/WEB

0

> Please follow https://youtrack.jetbrains.com/issue/WEB-15575 for updates. As a workaround you can try removing semicolons from live templates in Settings | Editor | Live Templates | Zen CSS

This is crazy to me that you don't have support for Stylus syntax. There is no other way? No ETA when you have support for Stylus?

 

> This can't be configured; please feel free to file a feature request to youtrack, https://youtrack.jetbrains.com/issues/WEB

So you are saying that we have to do a manual reverse tab every time we have to start writing a new class name? I would not say I am a pro at writing SCSS or Stylus but when I write Stylus in Sublime it is much more effective.

 

EDIT: I found this and it seems that nothing has happened since 2013 in the Stylus area? https://blog.jetbrains.com/webstorm/2013/10/stylus-in-webstorm-7/

0

>This is crazy to me that you don't have support for Stylus syntax. There is no other way? No ETA when you have support for Stylus?

 

We do have support for Stylus. This issue is about not using `:` in Emmet templates, not about Stylus support

And no, there is no ETA for the fix. You can vote for youtrack ticket to be notified on any progress with it

0

Please sign in to leave a comment.