2017.4 hangs during indexing.

My current status is that I have re-booted and restarted WebStorm, but it starts indexing, and then simply hangs and won't respond to anything. In addition I have a Update Dependencies Info window active but it also doesn't respond.

 

I have been looking for log files, but I am not sure where they are.

13 comments

In the meantime I am going to re-install the latest version

0

please try disabling .ignore plugin - does the issue persist?

0

will try shortly

 

is there a way to do that before starting the .exe? Because I can't get control of the process

0

Try deleting the `~\.WebStorm2017.2\config\plugins` folder. Or, ever better, remove the whole  `~\.WebStorm2017.2` directory

0

Well, I should probably have just deleted the plugins folder, but I deleted the whole folder, as well as my older versions, which I realize now I should have left until after the import of all those lovely settings and configuration stuff. Cest la vie.

 

Anyway, So, you are saying the .ignore plugin was causing my issues?

0

yes, from the dumps it seems that it is blocking the file index building

0

Well that does seem to clean-up the present issue. 

If, at my advanced years, I can remember this conversation, I will resolve this a little differently and less painfully next time.

 

Thank you

0

I had the same problem after upgrading to 2017.2.4. Disabling the `.ignore` plugin did the trick. Thanks! 

2

Same as Chris Grayson. After upgrading to 2017.2.4 (though not WebStorm but IntelliJ IDEA) I had the same issue, which also resulted in incomplete indexes, i.e. some classes/files didn't show up in the corresponding search box.

0

I can understand, that a plugin can be a problem, however what I have an issue with is that 2017.2.4 doesn't seem to recognize that it needs to disable the plugin. Even after trashing all my plugins and starting from scratch, I still get an occasional "loss of control" situation where I have almost no choice but to button hold the power button, because I just can't get the OS to respond sanely. 

0

Please sign in to leave a comment.