Swift inspections not working



I'm running the latest version of AppCode (AppCode 2017.2.3 Build #OC-172.4155.34). But Swift inspections do not work. They're turned on but I have to compile the code to actually see compiler warnings and errors.

The same inspections work fine in XCode (Version 8.3.3 (8E3004b)).

I've tried removing AppCode, deleting all of it's preferences and cache and even restarting my computer. But nothing makes any difference.

Any ideas?!

Official comment

Try to build the target against iOS device and reopen .swift file - it should help.

Strangely that seems to have fixed the issue... Thanks!


I'm having the same problem with 3rd party frameworks and such.  Works fine in Xcode but not in AppCode.  I'm new to AppCode (evaluating it) so trying to figure this out.  I tried building for my target sim, etc. but it still won't pick up anything.


>I tried building for my target sim

Have you tried to build the target for device or simulator? Building for device should help in general - in case it doesn't, try cleaning build folder & re-build for device once again.


It eventually started working.


They mostly don't work for me, even on 2018.RC1. Here are two screenshots: https://www.dropbox.com/s/nmvv7lib4h57poq/some_show.png?dl=0, https://www.dropbox.com/s/klaaoxe7mugpozl/most_do_not.png?dl=0. Doesn't matter if I build or not and all tasks (like indexing) are finished.



Have you built for device? In case you did, and it's still an issue, please submit a ticket in our tracker, we'll investigate.


Please sign in to leave a comment.