Can't set a ruby interpreter

I select Configure Ruby Interpreter

I select the version I want, Apply un-greys but doesn't do anything and clicking ok makes the window vanish, but doesn't assign the Interpreter, going back in to preferences the version I'd selected is unchecked.

The error log contains nothing.

2 comments

Could you please attach idea.log (Help | Show log in...) and just in case if you have multiple projects, check that you select SDK for all of them.

0

I solved it, but I had to open a different directory, then re-open the one with the project in and it let me add an interpreter

0

Please sign in to leave a comment.