How to turn off database names in table editor tabs?

Since I upgraded to 2017.2.1 it started appending [database name] on table editor tabs.

Is there a setting to turn this off so it only shows the table name in the tab?

 

thanks,

Alex

2
8 comments

Hi there,

Select that database as default one perhaps?

Please check "Settings/Preferences | Languages & Frameworks | SQL Resolution Scopes"

0

Doesn't work for me - anyone tried it already, any other ideas?

0

You can disable it at Settings/Preferences | Tools | Database | Always show qualified names for database objects.

0

@Eugene Morozov - Doesn't work as well.

I didn't mentioned - I'm on RubyMine, but I supose database plugin is the same across all IDEs.

Maybe it's a bug? I'll report this.

Funny thing is when an IDE is starting-up database name is blinking - it disapearing for a second, then appears again.

0

It's 2024 and still there seems to be no way of getting rid of these “connection name” suffixes in the tab names. This is sad, because they take up unnecessary space etc.

Using the latest (as of now) version of DataGrip 2023.3.3.

1

I confirm this. It's very annoying, because the [connection_name] part is repeated in every opened tab with a table editor. There must be a way to disable that!

0

@ Bora 

I ended up making one data source (connection) per Project. So instead of 4 different connections in one project I now have 4 different projects which I open each in a separate window. The result now is very clean, distinguishable and no connection names in the tabs anymore.

More information regarding  projects can be found in the official documentation here: DataGrip projects.

 

0

Levan Kekelidze, thanks for the idea! Seems I'll follow this way too.

I actually had one project configured with single data source, but rarely used it to notice that there were actually no [connection] in tab names)

Thanks again! 

1

Please sign in to leave a comment.