SWIFT_VERSION is not recognized when set to Swift 4 in AppCode 2017.2.3

Completed

In preparation for the upcoming release of iOS 11 and Xcode 9, I have started to transition to using Swift 4. I have our project fully migrated and working in the beta version of Xcode 9, including disabling objc inference. However, when I try to build the project in AppCode, I get an error stating that the SWIFT_VERSION is improperly configured.

Is there anything I need to change to get Swift 4 working in AppCode 2017.2.3?

Here are my settings:

Thanks!

1 comment

For those of you that run into this issue, you have to configure which version of Xcode that AppCode is using to build the project, which is found in Preferences > Tools > Xcode. 

0

Please sign in to leave a comment.