Intellij Play2 module not honored in run configuration

Have an multi-module SBT project with Play plugin configured for one of the modules.  From what I can tell, IntelliJ is not honoring the Run Configuration setting: "Play2 Module".

For example, in my project I have "root", "core" and "admin" modules, with the PlayScala plugin enabled for the "admin" module:

# <project root>/project/plugins.sbt
addSbtPlugin("" % "sbt-plugin" % "2.6.3")
# <project root>/build.sbt
lazy val admin = (project in file("admin")).enablePlugins(PlayScala).settings(commonSettings: _*).settings(
libraryDependencies ++= Seq(

lazy val root = (project in file(".")).settings(commonSettings: _*).aggregate(core, admin)


When running from IntelliJ, the run command displayed at the top of the Run console ends like this:

...omitted.../sbt-launch.jar" xsbt.boot.Boot run

Note that IntelliJ is not setting the SBT "project" to run from.  If I copy/paste that run command, but modify it slightly to include the correct project, the application starts OK:

...omitted.../sbt-launch.jar" xsbt.boot.Boot "project admin" run

 I would expect that the "Play2 Module" selected in the Run Configuration to be passed as the SBT project (as demonstrated in the 2nd example).  I've also tried to change the "Play2 Module" in the settings panel under "Languages and Frameworks > Play2 > Compiler" but that also doesn't seem to have any effect.

Anyone else experienced this?  

IntelliJ IDEA 2017.2.5 EAP (also tried 2017.2.4)
Build #IU-172.4343.2, built on September 14, 2017
Licensed to Aaron Hiniker
Subscription is active until June 6, 2018
JRE: 1.8.0_152-release-915-b12 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.6

Play 2

SBT: 0.13.15


This case requires investigation. I've created for further processing.


Is it possible to try this case in the latest 2017.3 IDEA EAP, with Scala plugin version 2017.3.5?


Please sign in to leave a comment.