PHPStorm not recognising PHP

Answered

14:28 Plugin Error
Problems found loading plugins:
Plugin "Blade Support" was not loaded: required plugin "PHP" is disabled.
Plugin "Drupal Support" was not loaded: required plugin "PHP" is disabled.
Plugin "Google App Engine Support for PHP" was not loaded: required plugin "PHP" is disabled.
Plugin "Joomla! Support" was not loaded: required plugin "PHP" is disabled.
Plugin "WordPress Support" was not loaded: required plugin "PHP" is disabled.
Plugin "PhpStorm Workshop" was not loaded: required plugin "PHP" is disabled.
Plugin "Behat Support" was not loaded: required plugin "PHP" is disabled.
Plugin "PHP Docker" was not loaded: required plugin "PHP" is disabled.
Plugin "Codeception Framework" was not loaded: required plugin "PHP" is disabled.
Plugin "PHPSpec BDD Framework" was not loaded: required plugin "PHP" is disabled.

This keeps sporadically happening, after several restarts all is fine again. Though wastes 10 mins each time its annoying that a product named PHPStorm forgets what php is.

8 comments
Comment actions Permalink

When this is happening, what state is the PHP plugin in?
Also, please upload the IDE log after PhpStorm restart somewhere (even better if you could collect it after the issue reproduces itself). Thank you!

0
Comment actions Permalink

Have same problem after install version 2017.2. In File Types i didnt see PHP group, only "PHP Files (syntax Highlighting Only)".

After installtion there was some composer init popup, i click init, and then restart, i think before this operation was no error.

UPDATE: after reinstall composer plugin was missing, i install again composer plugin and it looks working again

1
Comment actions Permalink

Same issue here all of a sudden (PHPStorm version 2018.3); has been working fine daily for months; never seen this before.  I have restarted iMac several times. Repaired disk permissions.  I'd upload the log files, however I got a warning saying they may contain sensitive info.  I've also invalidated caches and restarted PhpStorm.

UPDATE

I reinstalled Php Storm, overwriting old version and then tried to load a project.  Same error, but this time (maybe it was there before not sure) I noticed a link in the Event Log to enable Php Plugin.  I clicked that and PhpStorm restarted and now it's working.

0
Comment actions Permalink

Hi all, 

 

Had the same issue today , once you get a top bar offering to enable php plugin , it will take you to plugins.

There you will just need to update bash support plugin (will be marked blue) and restart.

That should resolve it.

I guess phpstorm was giving a confusing message.

1
Comment actions Permalink

I read Toni's suggestion, and despite thinking it sounded ludicrous, I figured I'd try. I couldn't update my bash plugin because it wasn't installed to begin with, but instead I installed it, and - lo and behold - it worked!

I suspect that it was really some sort of caching issue with PhpStorm's plugin list, and that making a change to a plugin (installing/updating probably any plugin) caused PhpStorm to fix it. Or it was the bash plugin thing, I don't really know.

PhpStorm 2017.3.4

0
Comment actions Permalink

Thanks @Ivarhk!  That worked.  I disabled the CVS plugin at random and restarted.  Lo!  PHP was back enabled in the app.

1
Comment actions Permalink

This was an issue for me today. All of a sudden PHP was missing from the 'languages & frameworks' section in settings and I couldn't use Xdebug. Followed the advice from @Toni Pap but instead of updating the plugin (as the option wasn't there) I uninstalled and reinstalled it. Sorted!

PhpStorm 2018.2.5

0
Comment actions Permalink

Disable CSV plugin

0

Please sign in to leave a comment.