Intellij IDE caret following cursor

Answered

Having an issue with IntelliJ where the caret (I-Beam thing - I think) follows the cursor without clicking. It will also start a selection when I do click as seen in the attachment below. I'm using the most up to date community edition of IntelliJ on arch Linux. It also happens within any pop out windows in IntelliJ, but not any other application. 

 

I have tried disabling all plugins, the problem persisted.

I have tried reinstalling IntelliJ, the problem persisted.

I also cannot right click because of this issue.

 

Any had this problem before or could help?

 

Thanks

19
48 comments

Oh well, I've been living with this issue for 2 years now, all until today when I had enough. Probably spent some days on system restarts. And all I had to do is touch the screen, damn ...

 

BIG THANKS! :D

3

Thank you guys. Touching the screen solved the problem. After trying everything from deleting temp files to doing a million "invalidates cache and restart", who knew i just had to touch the screen!

0

This problem happened to me a few times on

Ubuntu 18.04

PyCharm and IntelliJ IDEA both 2019

 

However, touching the screen didn't solve this problem. But logging out and then in solved it. As I wrote this, the problem suddenly went away (I touched the screen before, but nothing happened)...

0

Hi, i have the same problem and touching the screen solved the problem too.
This issue appeared in two applications: Idea and Telegram messager. Touching in Telegram solved the issue for both applications.

0

I also have this same issue,

i have a touch screen laptop, and this cursor issue occur sometime. Best easy way to deal with it is to just touch your screen once and the issue will be solve. what happen is when we use the touch of the screen, it happens to stuck in some application. you can touch the screen and it will be solved.

Thank you.

-2

i just registered to write a comment that this issue is still present in 2019.3.3 and i was going crazy about it and the 'touch the screen' thing works like a charm. LOVE IT!

0

Still there in IJ 2020.1

Thankfully, touching the screen fixes it, as long as you know you have to do it.

I never touch my screen when working in IntelliJ, and would have never tried it if not for the suggestion in this thread.

0

Yep. I confirm that touching the screen works.

0

Solution

1: Go to setting

2:search mouse

3: In editor action edit the Add rectangular selection on mouse drag

0

Touching the screen solved my problem also

0

The number of times i had restart my computer for this issue...! Touching the screen works like magic, thank you !

0

For me nothing helped. Especially not the touch screen fix, since my Ubuntu 21 doesnt even get the touch screen working on this Dell XP 15.
I tried restarts and all kind of config things.
But then, in my pain, I started to change display resolution down from 3840x2400 to lower. 
And suddenly it stopped doing this. Even going back to original resolution seemed to keep it working again. WTF.

0

Touching the screen has been fixing this for me. Thanks to the people who figured that out. Still, I have to wonder why, after five years (I think?) this usability bug has not been corrected.

0

Thanks folks, this one perplexed both me and a JetBrains support agent!

0

Foj Can't thank you enough

Fixed by touching the code with the touchscreen.

0

Same annoying problem.
Touch the touchscreen 

0

Please sign in to leave a comment.