Jade/Pug syntax highlighting for ECMAScript 6

 Hi, I am using Pug in an Angular-based app.  Most of the syntax highlighting works but I'm trying to use ECMAScript 6 template strings and they cause errors to be highlighted in the code.  Here is an example:

 

I've set the JavaScript lnaguage version to be ECMAScript 6 in Settings / Languages & Frameworks / JavaScript.  Is there anything else I can do to get this syntax to be accepted as valid?  If not, can I disable these errors for Pug files?

Thanks,
Kevin

 

Please sign in to leave a comment.