Any issues with High Sierra?

Answered

We're coming up on the GA release of High Sierra? Any issues that would prevent a Java developer and JetBrains customer from updating?

24 comments
Comment actions Permalink

Is it possible to resolve with a IDEA release or does it require a bugfix from Apple?

0
Comment actions Permalink

no problems at all. I have high sierra installed on a macrpo and on macbook pro and it works as it should.

0
Comment actions Permalink

It's not clear yet if the issue can be fixed on the side of JetBrains Runtime. It may also affect only some users.

0
Comment actions Permalink

Ever since upgrade to High Sierra I have serious performance issues with IntelliJ IDEA. I'm not sure if this is caused by the new file system. Our project is large but it was not causing performance issues before. 

5
Comment actions Permalink

Local history does not work for me. We do use bazel though.

0
Comment actions Permalink

You can try removing idea.system.path to reset the local history: https://intellij-support.jetbrains.com/hc/articles/206544519.

0
Comment actions Permalink

I've also had serious performance issues with pycharm and osx 10.13. It's to the point where I cannot use pycharm because editing a single file will cause my machine to spike in cpu utilization to the point where everything slows down and the pycharm editor pauses every second.

0
Comment actions Permalink

I tried to install fresh. it failed with "no mountable file systems"

raised bug: https://youtrack.jetbrains.com/issue/IDEA-182940

0
Comment actions Permalink

It looks like a problem with the download, verify the checksum. See also https://intellij-support.jetbrains.com/hc/articles/206544699.

0
Comment actions Permalink

I am having an issue with screen flicker. The screen turns briefly (300 ms maybe) black, then returns to normal. It seems to be associated when moving between desktops, but it doesnt happen all the time, maybe 3% of the time when I switch desktops. I cant tell if it happens any other time. I cant reproduce it so I dont know. It seems also occur more when I use intellij and webstorm. Much more with intellij. But again I cant reproduce it so I dont know. There is this thread on apple support. https://discussions.apple.com/thread/8106679

0
Comment actions Permalink

With the latest update of high Sierra PYcharm does not run anymore

0
Comment actions Permalink

Please file a ticket to support with the details of the problem. There should be some error if you try to run it from the Terminal.

0
Comment actions Permalink

it runs the program, the program just immediately stops responding, there is no error.

0
Comment actions Permalink

I'm seeing this when attempting to start PyCharm - macOS High Sierra 10.13.3.

Nothing in the ~/Library/Logs/PyCharm2017.3 folder.

Any ideas?

0
Comment actions Permalink

Try rebooting the system, there could be some problem with networking.

http://stackoverflow.com/a/39698914/104891 may also help.

Resetting the network is another thing to try: https://www.wikihow.com/Reset-Network-Settings-on-PC-or-Mac.

0
Comment actions Permalink

Hi Serge,

Thanks for the suggestions - unfortunately none of them seemed to help.

I've checked network usage with 'lsof', it doesn't look like there are any collisions - is there a comprehensive list of ports/addresses that PyCharm will use?

Thanks!

0
Comment actions Permalink

What does `hostname` command return? Can you ping the address returned by the hostname command?

0
Comment actions Permalink

A few folks on my team let me know of a workaround:

networksetup -createnetworkservice Local lo0 && networksetup -setmanual Local 127.0.0.1 255.255.255.0
 
PyCharm was trying to bind the following addresses (many times):
5.99.208.224
5.116.0.224
 
The above 'networksetup' command fixed it for me on High Sierra 10.13.3 and PyCharm Professional 2017.3.3
 
Cheers!
1
Comment actions Permalink

I found a very weird behavior after updating to High Sierra. It is when I press command + S, it did not save, instead it cut the latest text I typed into the new cursor. 

0
Comment actions Permalink

Check if this shortcut is redefined in globally in OS or configured in other program, e.g. if you have some keyboard manager installed.

Also check what action for the Cmd+S shortcut is defined in IDE Preferences | Keymap settings.

If you have any 3rd plugins installed try with them disabled.

0

Please sign in to leave a comment.