Typescript 2.5.2 compileOnSave = false

When I'm developing using typescript 2.5.2 the typescript compiler does not compile the code. In the Typescript console I see the following

Process: Message 13 'ideChangeFiles' server time, mills: 0
Process: Compile skip: compileOnSave = false
Process: Message 14 'ideCompile' server time, mills: 0
Process: Update project structure scheduler time, mills: 0

If I press the compile button it works as expected but the auto compile does not work.

Falling back to 2.4.2 resolves this issue.

Package.json

{
"name": "tmp",
"version": "1.0.0",
"description": "",
"main": "index.js",
"scripts": {
"tsc": "tsc"
},
"author": "",
"license": "ISC",
"dependencies": {
"typescript": "^2.5.2"
}
}

tsconfig.json

{
"compilerOptions": {
"target": "es5",
"lib": ["es6", "dom"],
"types": [ ],
"typeRoots": [
"./node_modules/@types"
],
"module": "commonjs",
"moduleResolution": "node",
"sourceMap":true,
"declaration": true,
"outDir": "./lib"
},
"exclude": [
"node_modules",
"postman",
"lib"
]
}

index.ts

console.log("Something")

Any suggestions would be helpful.

2 comments

It is a bug, https://youtrack.jetbrains.com/issue/WEB-28374

Workarounds:

  1. Add the "compileOnSave":true option to the tsconfig.json
  2. Use WebStorm version >= 2017.2.3
1

I did not see that issue in my searching. Thanks!

0

Please sign in to leave a comment.