java.lang.IllegalArgumentException: Not a file or directory: xxxxxx\.idea\modules\src\test\resources\features

Hi,

I'm getting the above compile error in my Scala test project and just cannot resolve.

My project structure is:

CucumberTest

-.idea

-project (sources root)

-src -> main -> scala

      -> test -> resources -> features -> firstFeature.feature

                  -> scala -> stepdefs (package) -> RunCucumber.scala

 

My RunCucumber class :-

package stepdefs

import cucumber.api.junit.Cucumber
import cucumber.api.CucumberOptions
import org.junit.runner.RunWith

@RunWith(classOf[Cucumber])
@CucumberOptions(
features = Array("src/test/resources/features"),
glue = Array("stepdefs"),
format = Array("pretty", "html:target/cucumber-report"),
tags = Array("@wip")
)
class RunCucumber {
}

I dont know why its trying to look in the .idea directory path to do the compile or where to change the configuration to resolve this?

When i created the scala project there was no resources directory in test, i had to create it (along with the features directory).

The error occurs when i run RunCucumber

Any advice please for a newbie? I understand the issue, just dont know the cause or how to resolve.

Cheers

 

3 comments
Comment actions Permalink

I've created a ticket https://youtrack.jetbrains.com/issue/SCL-12672 for a further processing. Is it possible to provide the project or at least some of the following information as attachment to the ticket?

Screenshot of

- project view. If it's higher than one screen - show the place where problematic file locates.

- project structure -> modules -> Sources 

- project structure -> modules -> Paths 

- project structure -> Project

IDEA logs after the error appears (Help menu -> Collect and Show Logs in Finder) 

 

0
Comment actions Permalink

Hi Anton - thanks for taking the time to reply.

I'm trying to complete the Scala SBT Cucumber tutorial that is here:

https://rubygemtsl.com/2014/08/01/scala-sbt-cucumber-and-selenium-webdriver/

I've downloaded the latest versions of IntelliJ, JDK9 etc.

When i follow the instructions, no resources directory is created :

I create the resources directory along with features etc but when i run RunCucumber, it throws the error and expects the directory path to be in the .idea path.

I've managed to set up Java Selenium and Scala projects okay but seem to be having a real problem with this.

Any help or pointers much appreciated (I've added the screenshots as an attachment to the ticket)

 

 

 

0
Comment actions Permalink

Got it. Thanks! We'll take a look.

1

Please sign in to leave a comment.