Is Find in Path Broken?

So in Angular after looking at a service, I wanted to find its uses. I used Find in path to search for uses, but although it came up in numerous Test Files, and Test Reports, I could not find any actual usage. I then asked a colleague, and we found another service that was using it. But Find in Path was unable to locate that service even though I am searching the entire project. 

Have Invalidated Caches and Restarted, and it still cannot find the string in a code file. 

Basically Find in Path is broken/erratic.

However when I open the file that contains the string, then Find in Path finds it.

Am coming to the conclusion that Find in Path is flaky / not reliable. Has anyone else actually checked that when you do this it actually finds them, becasue i suspect it is silently missing stuff that most people never realise!

this would be a Disaster during Refactoring across a project, and frankly would make using WebStorm like a Dinghy with a Hole in it. But I don't get how JetBrains could allow such a bug thru, at present it jars when i see it being called the Smartest Javascript IDE!!! Not being able to do a Find All reliably is Dumb.


@Andriy Bazanov sorry i don't get why i need to create a ticket for this. I do not get why you are unable to raise a ticket to fix it. and reference this thread. Thanks.



2 very simple reasons:

1) I do not have any issues with the search -- at very least those that are described here. It's you who are interested in these changes.

2) I do not work for JetBrains... and therefore cannot fix their product. And submitting a ticket with "Hey devs, there is some guy on the forum that does not like how the Find in Path dialog works. But he is too busy/too lazy/whatever to come here and write that ticket himself .. so here is the link -- go and check what he wants" kind of text ... not really.


I have the same issue with javascript files in that find (in path or otherwise) does not work. Neither does 'Find Usages'.

I am running

IntelliJ IDEA 2017.3.3 (Ultimate Edition)
Build #IU-173.4301.25, built on January 15, 2018
JRE: 1.8.0_152-release-1024-b11 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.6

This issue presented itself in 2017.3, 2017.3.1 and 2017.3.3 but not in 2017.3.2.

None of the "fixes" described above work. This is very frustrating since I have to do a clean checkout and use an older 2016 version to do any work. The IDE is almost unusable since when find stops working, because then so does most of the syntax highlighting.



I use Intellij IDEA 14.1.7 and can confirm that this helped for me:

- uninstalling the plugin .ignore

- afterwards Invalidate Caches / Restart

Looks like there might be a problem with the plugin..."


Works like a charm - Thanks!


I've encountered this problem as well. I have some file paths in my dev config files. Bad practice, I know, but that's irrelevant here.
When I search for all occurences of "ssd" (Find in path, with tab "In project", no filters) it finds nothing. Even after Invalidate Cache / Restart. But this string definitely is present:

martin (master *) PspValidator $ grep 2>/dev/null ssd */*/*/*/*/*

Here is my project where this happens in last commit still containing the "ssd" string:

This happens in IC-173.4548.28 and IC-181.3263.15 as well.
JDK: 1.8.0_161 (build 1.8.0_161-b12) amd64 (Oracle)

Search in IDE not working reliably is obviously very serious problem!


I am having this problem as well.

Intellij fails to find strings in my .properties and .xml files.

This is a major productivity killer and bug-introducer, please fix


Find in Path has become completely worthless to me in Webstorm.  I do not understand why they can't make it work reliably.


@TimHardy I agree, something as basic as Find in Path ought not be that hard, and as @ThomaszMinkowski noted is a productivity killer and potential bug introducer. I do however still continue with Webstorm as I like its other features. Although you shouldn't really need to, one option is to use grep to search for the string recursively if it looks like Webstorm is missing stuff. So after a refactor you could do that just to be sure Webstorm has not missed out some files.


I use AgentRansack to find things in my WebStorm projects.  It works reliably and intuitively, but yes, it's a pain to have to use an external tool for something as simple as find in files.


Should this issue not be created as a ticket in in order to get the attention of the devs?

I don't see many issues there that mention these problems.

Maybe create a ticket with a link to this discussion?


Problem reproduced on Windows 10 

Intellij 2017.3.5 Ultimate Edition.


Find all in path (scope Project) failed to find all xml files. When I explicitly activated extension filters and set it as *.xml, it found the lines in xml. However, deactivating the filter and trying to find any occurrences resulted in incomplete results (I was lucky since I knew what I was searching for this time).

It's not a "Feature" because clearing the cache as instructed above made the results come up normally again. It's a bug.


And it's a really bad bug because there will be times when it's impossible to know if the results are complete or not - and it will lead to nasty bugs if not lucky enough to be caught on compile time.


Please acknowledge the bug and start working on it if possible.



@Remco thanks, i have just now created an issue on youtrack

Feel free to elaborate on the ticket.


@Mickeypuri Thanks. I was just doing the same, you beat me :-). I hope this issue will get some well deserved attention now.

Please upvote the issue everybody.


Devs are asking for screenshots and proof. Please provide here if you have any:


- Also posted in the RubyMine forum, this is a duplicate in case it adds to the issue, expect response in RubyMine  Forum -

I would request that a label saying 'Only first 100 instances listed, may appear elsewhere' be slapped on top of the Find In Path results popup window in RubyMine.

I'm a big fan of RubyMine.

This issue has recently caused me some wasted time.

I had removed a column from a database and my automated tests were failing because they were expecting the column. I searched for it in the code and although it appeared many times in a generated errors web page and a log file (over 100 times :) ) it didn't appear anywhere else.

For the life of me I couldn't understand why the tests were looking for the column.

I had assumed '100+ matches in 6 files' mean't that it only was found in those six files which I knew weren't causing the problem.

Now it seems I will need to do a Find In Path and then Open in Find Window if the result set is 100+.

I tried to adjust the property but apparently that's not possible in my version of RubyMine.

Is there a process where I can search and go straight to the Open in Find Window view ?




I had `Find in Path` break, too, but messing with plugins and cache invalidations didn't fix it.

However, I did find a solution to the CLion bug that caused my particular breakage. This is the issue I created that also gives the solution: 

In short, there's a bug in CLion's implementation surrounding regex search/replace. CLion had mistakenly stored an invalid regex search/replace pair from an unsuccessful replace attempt in an editor (not in the Find in Path dialog directly) that happened much earlier in my session. To fix it, I had to edit `/.idea/workspace.xml` as described in the CPP-13327 issue I linked to above.

Hope that helps any other regex users that got caught by this frustrating bug!



Hi same problem here.

Find in Path fails to see all occurrences.

I just started using Intellij IDEA, it seems good (even if i need to configure it a lot since most defaults are terrible for my habits), but i was finally starting to get used to it and i must say it's quite faster than my previous IDE.

Unfortunately i must say this search issue is a very big problem for me, since the bug is completely silent.

Reading previous comments I see this problem is very common and is still there by more than 2 years now....this is a serious problem preventing me from using the IDE.

Just to be clear: This CANNOT BE a Feature! (like someone in the comments said)

It doesn't limit results by any meaningful criterion, unless you think that 6 results in 4 files are too much and you have to limit them to 4 results in 2 files....

By the way, "Find in Path" popup manage to see 5 matches in 2 files, while the Find Window only get 4 in 2 it is probably more than one bug, or it just behaves differently depending on the tool used.


Currently, after verifying a lot of missed occurrences in various test searches that i have run, I decided to get back to *AnotherIDE* because search in files is a core feature and i must be sure i can rely on it.

Also, I do not have any intention of wasting my time over a issue more than 2 years old with people like Andriy Bazanov that seems to pretend it's just not there...

I'll check again your IDE in some moths, hoping for this problem to have been solved.





IntelliJ IDEA 2018.1.1 (Ultimate Edition)
Build #IU-181.4445.78, built on April 10, 2018
Licensed to Nick Mellor
Subscription expired on July 1, 2018
JRE: 1.8.0_152-release-1136-b27 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 3.10.0-514.26.2.el7.x86_64

Statistic 3.4.1

I am getting this problem too, and it had mild professional consequences that I don't want to repeat.

A few weeks ago I was upbraided by my manager because one of my refactorings missed a couple of instances of a particular variable name. The cause? Replace In Path didn't do its job correctly. I was made to look careless and slapdash. I'm a loyal Intellij user but this was not a good look, for me or Intellij IDEA Ultimate. It also doesn't make it easy to sell Jetbrains products to my colleagues.

Here's my take on it. It seems to me that plugins are involved. My suspicions were first aroused by .ignore, then Statistic 3.4.1. .ignore seems to have been fixed recently, but when Statistic is enabled Find in Path sometimes doesn't find stuff. When I disable Statistic and Intellij rebuilds the index, Find in Path becomes trouble-free again, and stays trouble-free for weeks or months until shortly after I re-enable Statistic.

I haven't looked hard at this and I'm not promising this is the cause, but this is my impression over several months. Find in Path has failed several times for me over the past year. It has always failed when one or both of these plugins were active.

I want you to understand that I don't blame Statistic or .ignore. If they are buggy, that's a separate issue. What concerns me more is that core feature Find in Path appears to be dependent on non-core plugins working correctly.

My guess is that it's because the plugin manages to derail Intellij's indexing process. If this is indeed so then it is a flaw in the IDE's plugin architecture that needs fixing. Making a core feature subject to the whims of a non-core plugin is a recipe for trouble and you will never be free of this trouble returning when the next version 0.1 of a plugin comes online and blows up the indexing.

Come on Jetbrains, yes Jetbrains, fix this as a matter of urgency and stop embarassing me in front of my colleagues!




IntelliJ IDEA 2017.3 and 2018.2: Find in Path (In Project) fails to find any matches if the Javascript Support plugin is enabled.  Here are the tests I ran:
- Disabled all plugins.  Invalidated Caches and Restart.  Find in Project worked.
- Enabled JavaScript Support (which also enables CSS Support).  Invalidated Caches and Restart.  Find in Project failed.
- Disabled JavaScript Support (CSS Support still enabled).  Invalidated Caches and Restart.  Find in Project worked.
- Enabled JavaScript Support.  Invalidated Caches and Restart.  Find in Project failed.
- Enabled all plugins.  Invalidated Caches and Restart.  Find in Project failed.
- Disabled JavaScript Support plugin (which forced disablement of about 15 other plugins).  Invalidated Caches and Restart.  Find in Project worked.
- Enabled JavaScript Support plugin (which forced disablement of NodeJS).  Invalidated Caches and Restart.  Find in Project failed.


@norm can you recreate the issue in a new project? project, steps to repeat and idea.log would be appreciated


Sounds like there are two different issues being discussed here... I've seen multiple tickets referenced for folks struggling with 'Find in Path' that's _actually_ broken, but for those of us who are merely appalled at the by a UI that gives almost no mention of the fact that it's limiting result to the first 100, it looks like somebody just created one here:

Not sure if it will last since it seems the feature WAI, buy hey, at least I tried :)


"Find in Path really shows a preview only (top 100 results) " 


That is completely unacceptable behavior.  This has caused me to waste a lot of time a number of times.  How do I show ALL results ????


There is another consideration: what if I do Find and Replace All ??  Will it will not replace all occurences (but only the first 100) ??


Find in Path is totally broken! Switching to VS Code, I got enough.


In my case it was because "Recursively" checkbox was not checked.


IntelliJ IDEA 2018.1 (Ultimate Edition)
Build #IU-181.4203.550, built on March 26, 2018
JRE: 1.8.0_152-release-1136-b20 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0


I do not have the ignore plugin installed.


Find all in path found several instances but did not find the ones I was looking for and knew existed. I was able to find it, easily enough in the file I had opened at the time.


This is an extremely concerning bug. Can anyone provide a status update on its progress?


@Stephen Boesch in the lower right-hand corner of the Find All popup you will see a button that reads "Open in Find Window", click that or press ctrl + enter to see all results.


I did try that also, and i found more results with the Find Window, but still not all of them!

I can't provide a description of the test, since i'm currently not using IDEA.

So please check with another tool (maybe notepad++) to see if the returned results are really all the occurrences.

I was just starting using the IDE for the first time, i didn't tinker with anything, i had last stable version with default plugins and all default stuff.


Yeah, my situation was basically the same, but I also tried the Find Window and i can confirm that i wasn't seeing all occurrences. My searched term had multiple occurrences in multiple files, and not all occurrences/files were found.


Please sign in to leave a comment.