PHPStorm scrambles  

PHPStorm scrambles  

when I click on that everything is fine.

Disabling the folding doesn't have any effect at all.

13 comments

Hi there,

Please show you Code Folding settings page. AFAIK it has to be one of the options there, most likely "XML Entities" (my educated guess)

 

>Disabling the folding doesn't have any effect at all.

Try closing and reopening the file. Is still the same -- restart IDE -- it most likely remembers the sate of currently opened/recently closed file.

0

disabled both of the xml options.

restart or reopening the file does not help. even a full reinstall does not (did so because I left out some updates in the past anyway)

for me looks like its encoding depending!?

 

0

Turning on/off "XML Entities" option does work for me (tested in complete HTML file; PhpStorm 2017.2.4 on Windows 10). Maybe it depends on file type (e.g. does not work in Twig/Blade template or something -- but it works for me even there)?

Default/Project/IDE encoding are all set to UTF-8

Actual file (test.html):

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
</head>
<body>
<div id="hello">
    <p>&nbsp; &lt; &gt; &amp; &quot; &apos;</p>
    <p>&hellip; &euro; &sect; &larr; &trade; &para; &pound; &mdash; &copy; &reg;</p>
    <p class="wuf">If one's own</p>
</div>
</body>
</html>
0

when copying the file content to a new file, saving that and reopening that, there is no folding for the &nbsp; and shows up correctly

0

Try "File | Invalidate Caches..." and restart IDE then -- may help.

0

Nope, no change. It started some days ago. no update has been done or anything else. really weird.

 

0

Anything interesting in the idea.log (Help | Show Log in...)? Maybe some plugins updated?

(You can try starting from scratch though -- backup and delete IDE-wide config files. if it works -- most of the important stuff can be restored back from backup (like Keymap/Live Templates/External Tools/Color Schema and other "exportable" settings))

Otherwise no ideas from my end.

 

0

Still no change - seems to be file related?!

0

Maybe - please upload it somewhere and share the link (so no info get lost when copy-pasting)

BUT to be honestly -- with that option disable it SHOULD NOT collapse them regardless of the file. I would rather expect other way around -- that it would fail to collapse because it does not detect the context right or something.

0

the file contains confidential stuff...so an upload is not possible. It's really weird. When d/l that file locally on open it everything is fine

 

0

Even the tooltip when moving the mouse over the folded code works perfect. It looks so much like a UTF8 character....but that does not make any sense

 

0

Unchecking Editor | General | Code Folding > XML Entities works for me too.

What PhpStorm version do you use?

0

Please sign in to leave a comment.