The file is too large: XXXM. Showing a read-only preview of the first 2.56M.

I regularly work with CSV file sizes ranging from about 500MB to multi-gigabyte. Given that I am using a 64-bit OS with 24GB of available physical RAM, why can't / won't DataGrip open files larger than 2.56MB?

4 comments
Comment actions Permalink

Because we index them, James! We are trying to improve this, but now you have these kinds of restrictions.

1
Comment actions Permalink

Maxim Sobolevskiy I know this has been stale for a very long time already, but I stumbled upon this issue today, am searching for a workaround and didn't find much in the IntelliJ documentation. Any updates?

0
Comment actions Permalink

Hello! We are now working on large files viewer, but if you are confident with your RAM, you can tweak the registry key of your IDE:

idea.max.content.load.filesize


To access the registry call Find Action (Ctrl/Cmd+Shift+A) and then type 'registry'

0
Comment actions Permalink

EDITED

Removed my comment. As I missed the topic "DataGrip".

Sorry for the noise.

0

Please sign in to leave a comment.